Вопрос задан 26.06.2023 в 13:24. Предмет Информатика. Спрашивает Корсаков Женя.

Напишите программу на "python" которая генерирует случайный пример на сложение двух чисел,

например "Сколько будет 17 + 13?"Программа предлагает пользователю ввести решение примера.Если решение введено верно, программа выводит "Верно"Если решение неверное - выводит "Неверно"Далее программа предлагает продолжить решать примеры, если пользователь вводитс клавиатуры слово stop, программа останавливается, если нажимает Enter -программа предлагает на решение ещё один пример."Продолжим? Нажите Enter ля решения другого примера, введите stop для окончания"Кроме того, если количество решенных примеров больше 5, то программа заканчивает выполнениевыводя "Ты хорошо справился, думаю на сегодня хватит"При завершении программы должен выводиться результат - количество правильно решенныхпримеров. "Количество верных ответов: 4"Если количество верных решений больше 5, программа выводит "Молодец"Если меньше: "Потренеруйся ещё"​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Янковская Маша.

from random import randint

class G:

def __init__(self):

 self.wins = 0

def menu(self):

 print("stop - для остановки решения\nEnter продолжение.")

 while 1:

  if self.wins > 5:

   print("Ты хорошо справился, думаю на сегодня хватит")

   G.result(self)

   break

  a = input(": ")

  if a == "stop":

   G.result(self)

   break

  elif a == "":

   G.game(self)

  else: pass

def game(self):

 n1,n2 = randint(1,100),randint(1,100)  # примеры от и до

 print(f"Сколько будет: {n1} + {n2}?")

 if int(input("Ответ: ")) == n1+n2:

  print("Верно")

  self.wins += 1

 else:

  print("Неверно")

 if self.wins != 5+1:

  print("Продолжим? Нажите Enter ля решения другого примера, введите stop для окончания")

def result(self):

 print("игра остановлена")

 print(f"Количество верных ответов: {self.wins}")

 if self.wins > 5:

  print("Молодец!")

 else:

  print("Потренируйся ещё")

a = G()

a.menu()



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот программа на Python, которая выполняет описанные вами действия:

python
import random def generate_question(): num1 = random.randint(1, 20) num2 = random.randint(1, 20) answer = num1 + num2 question = f"Сколько будет {num1} + {num2}?" return question, answer def main(): correct_answers = 0 total_questions = 0 while True: if total_questions >= 5: print(f"Ты хорошо справился, думаю на сегодня хватит\nКоличество верных ответов: {correct_answers}") if correct_answers > 5: print("Молодец!") else: print("Потренеруйся ещё") break question, correct_answer = generate_question() print(question) user_answer = input("Введите ответ или введите 'stop' для завершения: ") if user_answer.lower() == 'stop': print(f"Количество верных ответов: {correct_answers}") if correct_answers > 5: print("Молодец!") else: print("Потренеруйся ещё") break try: user_answer = int(user_answer) if user_answer == correct_answer: print("Верно") correct_answers += 1 else: print("Неверно") total_questions += 1 except ValueError: print("Неверный формат ответа. Пожалуйста, введите целое число.") if __name__ == "__main__": main()

Вы можете скопировать этот код и выполнить его в среде Python. Он будет генерировать случайные примеры сложения, проверять ответы пользователя и выводить результаты в соответствии с вашими требованиями.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос