Вопрос задан 26.09.2023 в 18:45.
Предмет Информатика.
Спрашивает Федів Антон.
СРОЧНО, 40 БАЛЛОВ!!! Напишите программу, которая в последовательности натуральных чисел определяет
количество чисел K, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности N, а затем сами числа. Программа должна вывести одно число - количество чисел K, оканчивающихся на 4. Язык программирования - Паскаль!Ответы на вопрос
Отвечает Мушков Кирилл.
var
k,n,i:integer;
begin
k:=0;
readln(n);
for i:=1 to n do
begin
readln(n);
if n mod 10 = 4 then
inc(k);
end;
writeln(k);
end.
Если моё решение вам помогло, отметьте его как лучшее. Спасибо! Удачи!
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи на языке программирования Паскаль, вы можете использовать следующий код:
pascalprogram CountNumbersEndingWith4; var N, K, i, num: integer; begin K := 0; // Инициализируем счетчик K // Вводим количество чисел в последовательности write('Введите количество чисел в последовательности: '); readln(N); // Вводим сами числа и проверяем, оканчиваются ли они на 4 for i := 1 to N do begin write('Введите число ', i, ': '); readln(num); if num mod 10 = 4 then K := K + 1; // Если число оканчивается на 4, увеличиваем счетчик K end; // Выводим количество чисел K, оканчивающихся на 4 writeln('Количество чисел, оканчивающихся на 4: ', K); end.
Скопируйте этот код в среду разработки Паскаль и выполните программу. Она попросит вас ввести количество чисел в последовательности, а затем поочередно ввести сами числа. После этого программа выведет количество чисел K, оканчивающихся на 4.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
