
1. Составить программу, которая запрашивает Имя и приветствует Вас 13 раз. 2. Составить
программу- таблицу умножения чисел на 5. 3. Составить программу, которая запрашивала число n и выводила сумму чисел от 4 до n. 4. Составить программу произведения нечетных чисел от 2 до 11. ЗАДАНИЕ В ПАСКАЛЬ. СДЕЛАЙТЕ ПЖ У МЕНЯ НЕАТЕСТАЦИЯ А Я НИЧЁ НЕ ШАРЮ ПО ПАСКАЛЮ. ПРОСТО ИГРАЮ В ДОТУ И В КС. ОБЕЩАЮ БУДУ УЧИТЬСЯ В 9 КЛАССЕ НО ПОМОГИТЕ МНЕ ПЖ

Ответы на вопрос

Ответ:
1.
program (название на английском, пример: program abc);
begin;
var s:string;
Name, Hello: string;
write('Введите ваше имя');
readln(Name);
writeln('Здравствуйте, ',s);
readln(Hello);
for s:=1 to 13 do writeln(Name, ' ', Hello);
end.
2.
program (name);
var i : byte;
begin
for i:=1 to 10 do
writeln('5*',i,'=',5*i);
end.
3.
program (name);
var n,s:integer;
begin
writeln('Введите N');
readln(n);
s:=(4+n)*n div 2;
writeln('s=',s);
end.
4.
program (name);
var x,s: integer;
begin
s:=1;
For x:=2 to 11 do
If x mod 2=1 then
s:=s*x;
writeln('Произведение равно ', s);
end.



Конечно, я помогу вам написать программы на языке Pascal для выполнения указанных задач. Вот решения для каждой из них:
- Программа для приветствия 13 раз:
pascalprogram Greetings; var i: Integer; name: String; begin Write('Введите ваше имя: '); Readln(name); for i := 1 to 13 do Writeln('Привет, ', name); end.
- Программа для таблицы умножения на 5:
pascalprogram MultiplicationTable; var i: Integer; begin Writeln('Таблица умножения на 5:'); for i := 1 to 10 do Writeln('5 * ', i, ' = ', 5 * i); end.
- Программа для суммы чисел от 4 до n:
pascalprogram SumOfNumbers; var n, i, sum: Integer; begin Write('Введите число n: '); Readln(n); sum := 0; for i := 4 to n do sum := sum + i; Writeln('Сумма чисел от 4 до ', n, ' равна ', sum); end.
- Программа для произведения нечетных чисел от 2 до 11:
pascalprogram OddProduct; var i, product: Integer; begin product := 1; for i := 3 to 11 step 2 do product := product * i; Writeln('Произведение нечетных чисел от 2 до 11 равно ', product); end.
Скопируйте каждую программу в текстовый файл с расширением .pas и выполните ее в среде разработки Pascal, такой как Free Pascal или Turbo Pascal. Удачи в изучении программирования!


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili