Вопрос задан 07.09.2023 в 05:10.
Предмет Информатика.
Спрашивает Касьянова Саша.
Написать программу получения обратной записи 4 значного числа введенного с клавиатуры
Ответы на вопрос
Отвечает Носарева Анастасия.
Var a,b,c,d,e:integer;
begin
writeln('введите четырёхзначное число');
readln(a);
b:=a mod 10;
a:=a div 10;
write(b);
c:=a mod 10;
a:=a div 10;
write(c);
d:=a mod 10;
write(d);
a:=a div 10;
write(a);
end.
begin
writeln('введите четырёхзначное число');
readln(a);
b:=a mod 10;
a:=a div 10;
write(b);
c:=a mod 10;
a:=a div 10;
write(c);
d:=a mod 10;
write(d);
a:=a div 10;
write(a);
end.
Отвечает Бардош Женька.
// F#
open System;
[<EntryPoint>]
let main argv =
let rec getNumberFromConsole _ =
printf "Please enter a correct 4-digits number?\n"
let maybeInt = Console.ReadLine();
let mutable value = 0;
if Int32.TryParse(maybeInt, &value) && value >= 1000 && value <= 9999
then value
else (getNumberFromConsole null)
let rec power = function
| (x, 0) -> 1
| (x, n) -> x * power (x, n-1)
let getDigit sourceNumber digit =
(sourceNumber / (power (10, digit))) % 10
let number = getNumberFromConsole null
let resultNumber = getDigit number 0 * 1000 + getDigit number 1 * 100 + getDigit number 2 * 10 + getDigit number 3
printf "%d" resultNumber
Console.ReadKey true |> ignore
0
open System;
[<EntryPoint>]
let main argv =
let rec getNumberFromConsole _ =
printf "Please enter a correct 4-digits number?\n"
let maybeInt = Console.ReadLine();
let mutable value = 0;
if Int32.TryParse(maybeInt, &value) && value >= 1000 && value <= 9999
then value
else (getNumberFromConsole null)
let rec power = function
| (x, 0) -> 1
| (x, n) -> x * power (x, n-1)
let getDigit sourceNumber digit =
(sourceNumber / (power (10, digit))) % 10
let number = getNumberFromConsole null
let resultNumber = getDigit number 0 * 1000 + getDigit number 1 * 100 + getDigit number 2 * 10 + getDigit number 3
printf "%d" resultNumber
Console.ReadKey true |> ignore
0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для получения обратной записи 4-значного числа, введенного с клавиатуры, вы можете использовать следующий код на языке Python:
python# Получаем 4-значное число от пользователя
try:
num = int(input("Введите 4-значное число: "))
if 1000 <= num <= 9999:
# Преобразуем число в строку, затем развернем строку и снова преобразуем в число
reversed_num = int(str(num)[::-1])
print(f"Обратная запись числа {num}: {reversed_num}")
else:
print("Пожалуйста, введите 4-значное число.")
except ValueError:
print("Ошибка: Введите корректное число.")
Этот код сначала запрашивает у пользователя ввод 4-значного числа. Затем он проверяет, является ли введенное значение действительным 4-значным числом. Если введено корректное число, программа разворачивает его запись и выводит обратную запись. Если ввод не соответствует ожидаемому формату, программа выводит соответствующее сообщение об ошибке.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
