Вопрос задан 11.08.2023 в 18:17.
Предмет Информатика.
Спрашивает Кауфман Милана.
1. Составить программу вычисления S=1/2+1/4+1/8+…+1/128. 2. Задан массив. Составить программу
которая вводит с клавиатуры 10 чисел и выводит их в обратном порядке. ТУРБО ПАСКАЛЬ, ПОЖАЛУЙСТАОтветы на вопрос
Отвечает Бохан Богдан.
Проверил у себя обе программы - всё работает, у Вас тоже должно работать.
Задание 1).
Program Summ_S;
var
I, N, DENOMINATOR: integer;
S, SUMM: real;
begin
N:=1;
for I:=1 to 999 do begin
if DENOMINATOR=128 then begin
write('S = '+SUMM);
break;
end;
DENOMINATOR:=N*2;
S:=1/DENOMINATOR; // 1/1*2, 1/2*2, 1/4*2...
N:=DENOMINATOR;
SUMM:=SUMM+S;
end;
end.
Задание 2).
Program Massive;
var
num_1, num_2, num_3, num_4, num_5,
num_6, num_7, num_8, num_9, num_10,
number: longint;
i: integer;
begin
for i:=1 to 10 do begin
write('Введите число: ');
readln(number);
case i of
1:num_1:=number;
2:num_2:=number;
3:num_3:=number;
4:num_4:=number;
5:num_5:=number;
6:num_6:=number;
7:num_7:=number;
8:num_8:=number;
9:num_9:=number;
10:num_10:=number;
end;
end;
writeln('Введенные числа в обратном порядке: '
+num_10,num_9,num_8,num_7,num_6,
num_5,num_4,num_3,num_2,num_1);
end.
P.S Можно и по другому сделать, но я уже паскаль особо не помню.
Надеюсь помог, удачи :)
Задание 1).
Program Summ_S;
var
I, N, DENOMINATOR: integer;
S, SUMM: real;
begin
N:=1;
for I:=1 to 999 do begin
if DENOMINATOR=128 then begin
write('S = '+SUMM);
break;
end;
DENOMINATOR:=N*2;
S:=1/DENOMINATOR; // 1/1*2, 1/2*2, 1/4*2...
N:=DENOMINATOR;
SUMM:=SUMM+S;
end;
end.
Задание 2).
Program Massive;
var
num_1, num_2, num_3, num_4, num_5,
num_6, num_7, num_8, num_9, num_10,
number: longint;
i: integer;
begin
for i:=1 to 10 do begin
write('Введите число: ');
readln(number);
case i of
1:num_1:=number;
2:num_2:=number;
3:num_3:=number;
4:num_4:=number;
5:num_5:=number;
6:num_6:=number;
7:num_7:=number;
8:num_8:=number;
9:num_9:=number;
10:num_10:=number;
end;
end;
writeln('Введенные числа в обратном порядке: '
+num_10,num_9,num_8,num_7,num_6,
num_5,num_4,num_3,num_2,num_1);
end.
P.S Можно и по другому сделать, но я уже паскаль особо не помню.
Надеюсь помог, удачи :)
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Турбо Паскаль для выполнения задач:
Программа для вычисления S=1/2+1/4+1/8+…+1/128:
pascalprogram SumCalculation; var S: real; denominator: integer; begin S := 0; denominator := 2; while denominator <= 128 do begin S := S + 1 / denominator; denominator := denominator * 2; end; writeln('Sum S = ', S:0:2); end.
Программа для ввода и вывода чисел в обратном порядке:
pascalprogram ReverseArray; const MaxSize = 10; var arr: array [1..MaxSize] of integer; i: integer; begin writeln('Введите ', MaxSize, ' чисел:'); for i := 1 to MaxSize do readln(arr[i]); writeln('Числа в обратном порядке:'); for i := MaxSize downto 1 do writeln(arr[i]); end.
Скопируйте соответствующие фрагменты кода в вашу среду разработки Турбо Паскаль и выполните программы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
