Вопрос задан 31.07.2023 в 09:13.
Предмет Информатика.
Спрашивает Кочетова Виктория.
Напишите программу, которая получает с клавиатуры номер месяца и выводит название соответствующего
ему время года или сообщение об ошибке. Пример: Введите номер месяца: 5 . В программе ПАСКАЛЬ!!! Не использовать caseОтветы на вопрос
Отвечает Котик Юлия.
Program n_5;
var
a: integer;
procedure Error;
begin
write('ERROR');
exit;
end;
begin
write('Введите номер месяца - ');
readln(a);
if (a <= 0) or (a > 12) then
Error
else
if (a = 12) or (a = 1) or (a = 2) then
write('Зима')
else
if (a = 3) or (a = 4) or (a = 5) then
write('Весна')
else
if (a = 6) or (a = 7) or (a = 8) then
write('Лето')
else
if (a = 9) or (a = 10) or (a = 11) then
write('Осень');
end.
var
a: integer;
procedure Error;
begin
write('ERROR');
exit;
end;
begin
write('Введите номер месяца - ');
readln(a);
if (a <= 0) or (a > 12) then
Error
else
if (a = 12) or (a = 1) or (a = 2) then
write('Зима')
else
if (a = 3) or (a = 4) or (a = 5) then
write('Весна')
else
if (a = 6) or (a = 7) or (a = 8) then
write('Лето')
else
if (a = 9) or (a = 10) or (a = 11) then
write('Осень');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Хорошо, вот программа на языке Паскаль, которая позволяет получить номер месяца с клавиатуры и выводит название соответствующего ему времени года или сообщение об ошибке без использования case:
pascalprogram Seasons; var monthNumber: integer; begin writeln('Введите номер месяца:'); readln(monthNumber); if (monthNumber >= 1) and (monthNumber <= 12) then begin if (monthNumber >= 3) and (monthNumber <= 5) then writeln('Весна') else if (monthNumber >= 6) and (monthNumber <= 8) then writeln('Лето') else if (monthNumber >= 9) and (monthNumber <= 11) then writeln('Осень') else writeln('Зима'); end else writeln('Ошибка: некорректный номер месяца'); end.
Программа сначала запрашивает у пользователя ввод номера месяца и затем использует вложенные условные операторы if...else для определения соответствующего времени года или вывода сообщения об ошибке, если номер месяца некорректный.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
