Вопрос задан 31.07.2023 в 07:01.
Предмет Информатика.
Спрашивает Миронов Сережа.
Составьте программу, которая будет определять положительное или отрицательное число ( программа
C++) заранее спасибо)Ответы на вопрос
Отвечает Смольський Богдан.
Усложним задание:
#include <iostream>
#include <string>
using namespace std;
template<typename T>
string sign(const T& x)
{
return x < 0 ? "negative" : x == 0 ? "0" : "positive";
}
int main()
{
cout << sign(-3.14f);
}
#include <iostream>
#include <string>
using namespace std;
template<typename T>
string sign(const T& x)
{
return x < 0 ? "negative" : x == 0 ? "0" : "positive";
}
int main()
{
cout << sign(-3.14f);
}
Отвечает Чепой Андрея.
#include<iostream>
using namespace std;
int x;
int main(){
cin>>x;
if(x>0) cout<<"Polozhitelnoye'';
else cout<<"Otritsatelnoye'';
return 0;}
using namespace std;
int x;
int main(){
cin>>x;
if(x>0) cout<<"Polozhitelnoye'';
else cout<<"Otritsatelnoye'';
return 0;}

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая определяет, является ли введенное пользователем число положительным или отрицательным:
cpp#include <iostream>
int main() {
int number;
// Запрашиваем у пользователя ввод числа
std::cout << "Введите число: ";
std::cin >> number;
// Проверяем, является ли число положительным, отрицательным или нулем
if (number > 0) {
std::cout << "Число положительное." << std::endl;
} else if (number < 0) {
std::cout << "Число отрицательное." << std::endl;
} else {
std::cout << "Число равно нулю." << std::endl;
}
return 0;
}
Пользователь вводит число, и программа выведет сообщение, указывающее, является ли оно положительным, отрицательным или равным нулю.
Примеры вывода:
Введите число: 5 Число положительное. Введите число: -3 Число отрицательное. Введите число: 0 Число равно нулю.
Если вы используете среду разработки, такую как Code::Blocks, Visual Studio или другую, вставьте код в файл с расширением ".cpp" и запустите его для выполнения.
Похожие вопросы
Информатика 345
Информатика 78
Информатика 94
Информатика 24
Информатика 965
Информатика 45
Информатика 64
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
