Вопрос задан 30.07.2023 в 02:23.
Предмет Информатика.
Спрашивает Соколов Даня.
1. Запишите на языке Паскаль: если N меньше либо равно 15, то M=2кореньN, иначе M=N-3. 2.
Определите значение переменной С после выполнения следующего фрагмента программы: А:=5; В:=60; А:=В-SQR(A); If A>B then C:=A*B else C:=A/5+11 3. Составить блок схему и написать программу вычисления значения выражения: М=3,14+корень n+30 —————————— 12Ответы на вопрос
Отвечает Васильева Полина.
1
program number1;
var n,m:real;
begin write('Введите N ');read(n);
if n<=15 then m:=2*sqrt(n)else m:=n-3;write(m);
end.
2
program number2;
var a, b,c:real;
begin a:=5;b:=60;a:=b-sqr(a);if A>B then C:=A*B else C:=A/5+11;write(c);end.
3
program number3;
var m,n:real;
begin write('Введите n ');read(n);
m:=3.14+sqrt(n)+30; write('М= ',m);end.
program number1;
var n,m:real;
begin write('Введите N ');read(n);
if n<=15 then m:=2*sqrt(n)else m:=n-3;write(m);
end.
2
program number2;
var a, b,c:real;
begin a:=5;b:=60;a:=b-sqr(a);if A>B then C:=A*B else C:=A/5+11;write(c);end.
3
program number3;
var m,n:real;
begin write('Введите n ');read(n);
m:=3.14+sqrt(n)+30; write('М= ',m);end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
- Пример кода на языке Паскаль:
pascalprogram Example1; var N, M: Real; begin write('Введите значение N: '); readln(N); if N <= 15 then M := 2 * sqrt(N) else M := N - 3; writeln('Значение M: ', M); end.
- Пример кода на языке Паскаль:
pascalprogram Example2; var A, B, C: Integer; begin A := 5; B := 60; A := B - Sqr(A); if A > B then C := A * B else C := A div 5 + 11; writeln('Значение C: ', C); end.
- Пример блок-схемы и кода на языке Паскаль для вычисления значения выражения:
Блок-схема:
diff+----------------------------------+
| Ввод значения n |
+----------------------------------+
|
v
+----------------------------------+
| Вычисление выражения |
+----------------------------------+
|
v
+----------------------------------+
| Вывод значения М |
+----------------------------------+
Код на языке Паскаль:
pascalprogram Example3; var n: Real; M: Real; begin write('Введите значение n: '); readln(n); M := 3.14 + sqrt(n) + 30 - 12; writeln('Значение M: ', M); end.
Примечание:
- В примере 3 я предположил, что "-" перед 12 в выражении является оператором вычитания, а не отрицанием числа 12. Если вам нужно отрицание числа 12, то просто замените "-" на другой знак, например "~" или используйте отрицательное значение числа.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
