Вопрос задан 29.07.2023 в 13:54.
Предмет Информатика.
Спрашивает Джарасов Амир.
Напишите программу на с++, которая в последовательности натуральных чисел определяет сумму чисел,
кратных 6 и оканчивающихся на 8. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 6 и оканчивающееся на 8. Количество чисел не превышает 100. Ввёденые числа по модулю не привышают 300. программа должна вывести одно число: сумму чисел, кратных 6 и оканчивающихся на 8. Пример: Входные данные: 3 18 25 48 Выход 66Ответы на вопрос
Отвечает Макалов Глеб.
#include "iostream"
#include <Windows.h>
#include <cmath>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int n, x;
int summ = 0;
int mas[100];
do {
cout << "Введите количество чисел в последовательности от 1 до 100: ", cin >> n;
}
while (n < 1 && n > 100);
for (int i = 0; i < n; i++){
do {
cout << "Введите " << i << " число: ", cin >> x;
} while (abs(x) > 300);
mas[i] = x;
if (x % 6 == 0){
summ += x; } else
if (x % 10 == 8){
summ += x;
}
}
cout << "Сумма чисел: " << summ << endl;
system("pause");
}
#include <Windows.h>
#include <cmath>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int n, x;
int summ = 0;
int mas[100];
do {
cout << "Введите количество чисел в последовательности от 1 до 100: ", cin >> n;
}
while (n < 1 && n > 100);
for (int i = 0; i < n; i++){
do {
cout << "Введите " << i << " число: ", cin >> x;
} while (abs(x) > 300);
mas[i] = x;
if (x % 6 == 0){
summ += x; } else
if (x % 10 == 8){
summ += x;
}
}
cout << "Сумма чисел: " << summ << endl;
system("pause");
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи можно написать следующую программу на C++:
cpp#include <iostream>
int main() {
int n;
std::cout << "Введите количество чисел в последовательности: ";
std::cin >> n;
int number;
int sum = 0;
std::cout << "Введите числа последовательности: ";
for (int i = 0; i < n; ++i) {
std::cin >> number;
if (number % 6 == 0 && number % 10 == 8) {
sum += number;
}
}
std::cout << "Сумма чисел, кратных 6 и оканчивающихся на 8: " << sum << std::endl;
return 0;
}
После компиляции и запуска программы, она попросит ввести количество чисел в последовательности. Затем по одному будут запрошены сами числа. После ввода всех чисел программа выведет сумму чисел, которые кратны 6 и оканчиваются на 8, как в вашем примере: "66".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 13
Информатика 13
Информатика 99
Информатика 19
Информатика 36
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
