ПОМОГИТЕ ПОЖАЛУЙСТА Дан фрагмент программы var s,t,A: integer; begin readln(s); readln(t);
readln(A); if (s > A) or (t > 12) then writeln ('YES') else writeln ('NO') end. Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел: (13, 2); (11, 12); (–12, 12); (2, –2); (–10, –10); (6, –5); (2, 8); (9, 10); (1, 13). Укажите наименьшее целое значение параметра A, при котором для указанных входных данных программа напечатает «NO» восемь раз.Ответы на вопрос
Ответ:
13.
Объяснение:
Заметим, что программа напечатает «NO», если переменная t будет меньше или равна 12, а переменная s будет меньше или равна А.
Из первой части условия получаем, что при вводе значений s и t (1, 13) программа напечатает «YES» вне зависимости от значения A. При отрицательных значениях A программа будет выводить «YES» больше одного раза.
Давайте проанализируем код и входные данные.
```pascal var s, t, A: integer; begin readln(s); readln(t); readln(A); if (s > A) or (t > 12) then writeln('YES') else writeln('NO'); end. ```
Условие вывода 'YES' выполнится, если либо `s > A`, либо `t > 12`. Если ни одно из этих условий не выполняется, будет выведено 'NO'.
Теперь рассмотрим входные данные:
1. (13, 2): `s > A` (13 > A), но `t <= 12`, поэтому 'YES'. 2. (11, 12): Оба условия не выполняются, поэтому 'NO'. 3. (-12, 12): `t > 12`, поэтому 'YES'. 4. (2, -2): `s > A` (2 > A), но `t <= 12`, поэтому 'YES'. 5. (-10, -10): Оба условия не выполняются, поэтому 'NO'. 6. (6, -5): `s > A` (6 > A), но `t <= 12`, поэтому 'YES'. 7. (2, 8): Оба условия не выполняются, поэтому 'NO'. 8. (9, 10): Оба условия не выполняются, поэтому 'NO'. 9. (1, 13): `t > 12`, поэтому 'YES'.
Теперь, чтобы программа вывела 'NO' в восьми случаях, нужно, чтобы восьми из девяти пар `(s, t)` не выполняли ни одно из условий (`s > A` и `t > 12`). Рассмотрим все пары:
1. (11, 12): Не выполняется `s > A` и `t <= 12`. 2. (-12, 12): Выполняется `t > 12`, но не выполняется `s > A`. 3. (2, -2): Не выполняется `s > A` и `t <= 12`. 4. (-10, -10): Не выполняется `s > A` и `t <= 12`. 5. (6, -5): Не выполняется `s > A` и `t <= 12`. 6. (2, 8): Не выполняется `s > A` и `t <= 12`. 7. (9, 10): Не выполняется `s > A` и `t <= 12`. 8. (1, 13): Выполняется `t > 12`, но не выполняется `s > A`.
Таким образом, для восьми случаев с 'NO' минимальное значение параметра A должно быть таким, чтобы не выполнялось ни одно из условий `s > A` и `t > 12`. Это происходит, когда `A >= 13`.
Таким образом, наименьшее целое значение параметра A, при котором программа напечатает 'NO' в восьми случаях, равно 13.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
