Вопрос задан 29.07.2023 в 13:09.
Предмет Информатика.
Спрашивает Тимашкова Софья.
КТО ЗНАЕТ ЯЗЫК ПРОГРАММИРОВАНИЯ "С++" 1.Напишите программу, которая выводила бы на экран
текстовую таблицу. 2. Дана диагональ телевизора в дюймах. Написать программу, определяющую эту же диагональ в сантиметрах. 3. Емкость аккумулятора смартфона составляет N мАч. Написать программу, определяющую минимальную емкость переносного зарядного устройства (powerbank), если необходимо 3 полных заряда смартфона. 4. За один день хомячок съедает K грамм корма. Написать программу, определяющую закупку корма в килограммах на 30 дней 5. Известно, что 1 дюйм равен 2.54 см. Разработать приложение, переводящие дюймы в сантиметры и наоборот. 6. Написать программуменю, которая выводила бы на экран название мобильного оператора и стоимость телефонного разговора за минуту. У пользователя необходимо запросить код мобильного оператора и продолжительность разговора. Определить затраченную на звонок сумму денег.Ответы на вопрос
Отвечает Грибанова Яна.
Ответ на первую, ниже.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программы на языке программирования C++. Ниже представлены решения для каждой из задач:
- Программа для вывода текстовой таблицы:
cpp#include <iostream>
#include <iomanip> // Для управления выводом
int main() {
// Заголовок таблицы
std::cout << std::setw(10) << "Имя" << std::setw(10) << "Фамилия" << std::setw(10) << "Возраст" << std::endl;
// Заполнение данных
std::cout << std::setw(10) << "Иван" << std::setw(10) << "Петров" << std::setw(10) << "25" << std::endl;
std::cout << std::setw(10) << "Мария" << std::setw(10) << "Иванова" << std::setw(10) << "30" << std::endl;
std::cout << std::setw(10) << "Алексей" << std::setw(10) << "Сидоров" << std::setw(10) << "22" << std::endl;
return 0;
}
- Программа для конвертации диагонали телевизора из дюймов в сантиметры:
cpp#include <iostream>
int main() {
double diagonalInInches;
std::cout << "Введите диагональ телевизора в дюймах: ";
std::cin >> diagonalInInches;
double diagonalInCentimeters = diagonalInInches * 2.54;
std::cout << "Диагональ телевизора в сантиметрах: " << diagonalInCentimeters << " см" << std::endl;
return 0;
}
- Программа для определения минимальной емкости переносного зарядного устройства (powerbank) для 3 полных зарядов смартфона:
cpp#include <iostream>
int main() {
int smartphoneBatteryCapacity;
std::cout << "Введите емкость аккумулятора смартфона в мАч: ";
std::cin >> smartphoneBatteryCapacity;
int requiredPowerbankCapacity = smartphoneBatteryCapacity * 3;
std::cout << "Минимальная емкость переносного зарядного устройства (powerbank): " << requiredPowerbankCapacity << " мАч" << std::endl;
return 0;
}
- Программа для определения закупки корма в килограммах на 30 дней для хомячка:
cpp#include <iostream>
int main() {
double foodPerDay;
std::cout << "Введите количество грамм корма, которое хомячок съедает за один день: ";
std::cin >> foodPerDay;
double foodFor30Days = foodPerDay * 30 / 1000;
std::cout << "Необходимая закупка корма на 30 дней: " << foodFor30Days << " кг" << std::endl;
return 0;
}
- Программа для конвертации дюймов в сантиметры и наоборот:
cpp#include <iostream>
int main() {
int choice;
double value;
std::cout << "Выберите действие: 1 - конвертировать дюймы в сантиметры, 2 - конвертировать сантиметры в дюймы: ";
std::cin >> choice;
if (choice == 1) {
std::cout << "Введите значение в дюймах: ";
std::cin >> value;
double result = value * 2.54;
std::cout << "Результат: " << result << " см" << std::endl;
} else if (choice == 2) {
std::cout << "Введите значение в сантиметрах: ";
std::cin >> value;
double result = value / 2.54;
std::cout << "Результат: " << result << " дюймов" << std::endl;
} else {
std::cout << "Некорректный выбор." << std::endl;
}
return 0;
}
- Программа-меню для расчета стоимости телефонного разговора с заданным мобильным оператором:
cpp#include <iostream>
int main() {
int mobileOperatorCode;
double callDuration;
double callCostPerMinute;
std::cout << "Введите код мобильного оператора: ";
std::cin >> mobileOperatorCode;
switch (mobileOperatorCode) {
case 1:
callCostPerMinute = 0.5; // Стоимость разговора для оператора 1
break;
case 2:
callCostPerMinute = 0.7; // Стоимость разговора для оператора 2
break;
case 3:
callCostPerMinute = 0.4; // Стоимость разговора для оператора 3
break;
// Добавьте другие кейсы для других операторов
default:
std::cout << "Оператор с указанным кодом не найден." << std::endl;
return 1;
}
std::cout << "Введите продолжительность разговора в минутах: ";
std::cin >> callDuration;
double totalCost = callDuration * callCostPerMinute;
std::cout << "Затраченная сумма денег: " << totalCost << " рублей" << std::endl;
return 0;
}
Обратите внимание, что данные программы просты и не содержат проверок на валидность введенных данных. В реальных приложениях следует добавить дополнительные проверки и обработку ошибок, чтобы обеспечить правильную работу программы в различных ситуациях.
Похожие вопросы
Информатика 12
Информатика 19
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
