Вопрос задан 29.07.2023 в 01:54.
Предмет Информатика.
Спрашивает Лобов Ярослав.
Помогите с экзаменом Pascal: 1 задача: треугольник задан координатами своих вершин на плоскости.
Составить программу, которая определит, является ли он равносторонним, равнобедренным или разносторонним 2 задача: Дано целое число N (N > 1). Найти наибольшее целое число i, при котором выполняется неравнество 3^i < NОтветы на вопрос
Отвечает Рейдла Сандер.
PascalABC.NET 3.4
function L(x1,y1,x2,y2:real):=Sqrt(Sqr(x2-x1)+Sqr(y2-y1));
begin
var (xa,ya):=ReadReal2('Введите координаты точки А(х,у):');
var (xb,yb):=ReadReal2('Введите координаты точки B(х,у):');
var (xc,yc):=ReadReal2('Введите координаты точки C(х,у):');
var a:=L(xb,yb,xc,yc);
var b:=L(xc,yc,xa,ya);
var c:=L(xb,yb,xa,ya);
var k:=a=b?1:0;
k+=a=c?1:0;
k+=b=c?1:0;
case k of
0:Writeln('разносторонний');
1:Writeln('равнобедренный');
else Writeln('равносторонний');
end
end.
****************
begin
var n:=ReadInteger('n=');
var i:=Trunc(Ln(n)/Ln(3));
if 3**i=n then i-=1;
Writeln(i)
end.
function L(x1,y1,x2,y2:real):=Sqrt(Sqr(x2-x1)+Sqr(y2-y1));
begin
var (xa,ya):=ReadReal2('Введите координаты точки А(х,у):');
var (xb,yb):=ReadReal2('Введите координаты точки B(х,у):');
var (xc,yc):=ReadReal2('Введите координаты точки C(х,у):');
var a:=L(xb,yb,xc,yc);
var b:=L(xc,yc,xa,ya);
var c:=L(xb,yb,xa,ya);
var k:=a=b?1:0;
k+=a=c?1:0;
k+=b=c?1:0;
case k of
0:Writeln('разносторонний');
1:Writeln('равнобедренный');
else Writeln('равносторонний');
end
end.
****************
begin
var n:=ReadInteger('n=');
var i:=Trunc(Ln(n)/Ln(3));
if 3**i=n then i-=1;
Writeln(i)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, помогу с решением задач на языке Pascal.
1 задача: Определение типа треугольника по его координатам.
pascalprogram TriangleType; type Point = record x, y: Real; end; function Distance(p1, p2: Point): Real; begin Distance := sqrt(sqr(p2.x - p1.x) + sqr(p2.y - p1.y)); end; function IsEquilateralTriangle(p1, p2, p3: Point): Boolean; begin Result := (Distance(p1, p2) = Distance(p2, p3)) and (Distance(p2, p3) = Distance(p3, p1)); end; function IsIsoscelesTriangle(p1, p2, p3: Point): Boolean; begin Result := (Distance(p1, p2) = Distance(p2, p3)) or (Distance(p2, p3) = Distance(p3, p1)) or (Distance(p3, p1) = Distance(p1, p2)); end; var A, B, C: Point; begin // Ввод координат вершин треугольника writeln('Введите координаты вершин треугольника A, B и C:'); readln(A.x, A.y); readln(B.x, B.y); readln(C.x, C.y); // Проверка типа треугольника if IsEquilateralTriangle(A, B, C) then writeln('Треугольник равносторонний') else if IsIsoscelesTriangle(A, B, C) then writeln('Треугольник равнобедренный') else writeln('Треугольник разносторонний'); end.
2 задача: Нахождение наибольшего целого числа i, при котором выполняется неравенство 3^i < N.
pascalprogram MaxPowerOf3; var N, i, power: Integer; begin // Ввод числа N writeln('Введите целое число N (N > 1): '); readln(N); // Нахождение наибольшего i, при котором 3^i < N power := 1; i := 0; while power < N do begin i := i + 1; power := power * 3; end; writeln('Наибольшее целое число i, при котором выполняется неравенство 3^i < N: ', i); end.
Обратите внимание, что в обеих программах предполагается, что пользователь вводит данные верно и корректно. Перед запуском программы рекомендуется протестировать ее на различных входных данных, чтобы убедиться в правильности результата.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
