Вопрос задан 28.07.2023 в 17:21.
Предмет Информатика.
Спрашивает Кроули Анастасия.
ДАЮ 30 Б Составить программу на языке Паскаль,возведения числа х в степень числа y.
Ответы на вопрос
Отвечает Пряничникова Даша.
Хорошо, если вы не используете функции и не используете библиотеки(типа crt)
var i, y, x, xy:integer;
begin
write('x=');
readln(x);
write('y=');
readln(y);
xy:=x;
for i:=1 to (y-1) do
begin
xy:=xy*x;
end;
writeln(xy);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы на языке Паскаль, которая осуществляет возведение числа x в степень y, можно использовать следующий код:
pascalprogram Exponentiation; var x, y, result: real; function Power(base, exponent: real): real; var i: integer; begin if exponent = 0 then Power := 1 else begin Power := 1; for i := 1 to abs(trunc(exponent)) do Power := Power * base; if exponent < 0 then Power := 1 / Power; end; end; begin writeln('Введите число x:'); readln(x); writeln('Введите степень y:'); readln(y); result := Power(x, y); writeln(x, ' в степени ', y, ' равно ', result:0:2); end.
Обратите внимание, что в приведенном коде используется функция Power, которая реализует возведение числа в степень. В ней предусмотрена обработка отрицательных степеней. После ввода чисел x и y, программа вычисляет и выводит результат возведения числа x в степень y с точностью до двух знаков после запятой.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
