Вопрос задан 28.07.2023 в 08:51.
Предмет Информатика.
Спрашивает Смирнягин Дима.
Нужно написать программу, которая переводит десятичные числа в двоичные. На языке Паскаль.
!!!Очень срочно!!!Ответы на вопрос
Отвечает Большешапов Женя.
// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018
// Внимание! Если программа не работает, обновите версию!
begin
var n := ReadInteger('Введите натуральное десятичное число:');
var r: string := '';
while n >= 2 do
(r, n) := (n mod 2 + r, n shr 1);
r := '1' + r;
r.Println
end.

Отвечает Куранова Тома.
Program l;
var
n: integer;
s: String;
begin
readln(n);
while n>0 do begin
insert(chr(48+n mod 2),s,1);
n:=n div 2;
end;
writeln(s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот программа на языке Паскаль, которая переводит десятичные числа в двоичные:
pascalprogram DecimalToBinary; var decimalNumber, quotient, remainder: Integer; binaryNumber: String; begin // Вводим десятичное число Write('Введите десятичное число: '); ReadLn(decimalNumber); // Проверка на неположительное число if decimalNumber < 0 then begin WriteLn('Ошибка: Введите положительное число.'); Exit; // Завершаем программу end; // Инициализируем пустую строку для двоичного числа binaryNumber := ''; // Переводим число в двоичную систему счисления quotient := decimalNumber; repeat remainder := quotient mod 2; binaryNumber := IntToStr(remainder) + binaryNumber; quotient := quotient div 2; until quotient = 0; // Выводим результат WriteLn('Двоичное представление числа ', decimalNumber, ': ', binaryNumber); end.
Просто скопируйте этот код в среду разработки Паскаля и выполните программу. Она запросит ввод десятичного числа и выведет его двоичное представление. Убедитесь, что введенное число положительное, иначе программа выдаст ошибку.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
