Вопрос задан 25.07.2023 в 22:16.
Предмет Информатика.
Спрашивает Шайдуллина Камиля.
Составить программу сортировки 2-х переменных по убыванию, письменно. На Pascal
Ответы на вопрос
Отвечает Улетова Маргарита.
var a,b:real;
begin
readln(a,b);
if a>b then writeln(a,' ',b)
else writeln(b,' ',a);
end.
Отвечает Талаков Денис.
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018
Внимание! Если программа не работает, обновите версию!
begin
var (a, b) := ReadReal2('Введите через пробел два числа;');
if a < b then Swap(a, b); // a - всегда не меньше b
Print('По невозрастанию:', a, b)
end.
Пример:
Введите через пробел два числа; 3.6 10
По невозрастанию: 10 3.6
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для сортировки двух переменных по убыванию воспользуемся простым алгоритмом обмена значений. Напишем программу на языке Pascal:
pascalprogram SortTwoVariables; var a, b, temp: Integer; begin // Ввод значений переменных a и b writeln('Введите значение a:'); readln(a); writeln('Введите значение b:'); readln(b); // Сортировка по убыванию if a < b then begin temp := a; a := b; b := temp; end; // Вывод отсортированных значений writeln('Отсортированные значения по убыванию:'); writeln('a = ', a); writeln('b = ', b); end.
В данной программе пользователю предлагается ввести два значения (a и b), после чего алгоритм сортирует их по убыванию и выводит отсортированные значения на экран.
Пример работы программы:
makefileВведите значение a: 7 Введите значение b: 3 Отсортированные значения по убыванию: a = 7 b = 3
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
