Вопрос задан 25.07.2023 в 18:37.
Предмет Информатика.
Спрашивает Смирнов Макс.
Напишите программу в pascal среди всех двузначных чисел подсчитайте количество кратных 3
Ответы на вопрос
Отвечает Шихалёва Маргарита.
var i,k:integer;
begin
i:=0;
for i:=10 to 99 do begin
if (i mod 3=0) then k:=k+1; end;
writeln('Количество двухзначных чисел кратных 3= ',k);
end.
Если понравилось решение - ставь 5 звезд и "Лучший ответ"!
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для подсчета количества двузначных чисел, кратных 3, можно написать программу на языке Pascal. Вот пример программы:
pascalprogram CountMultiplesOfThree; var count: integer; // Переменная для хранения количества чисел, кратных 3 num: integer; // Переменная для перебора чисел от 10 до 99 begin count := 0; // Инициализируем счетчик нулем // Цикл для перебора всех двузначных чисел for num := 10 to 99 do begin // Проверяем, является ли число кратным 3 if num mod 3 = 0 then count := count + 1; // Увеличиваем счетчик, если число кратно 3 end; // Выводим результат writeln('Количество двузначных чисел, кратных 3: ', count); end.
Программа перебирает все двузначные числа от 10 до 99 и проверяет, делится ли каждое число на 3 без остатка. Если число кратно 3, счетчик увеличивается на 1. В конце программа выводит количество двузначных чисел, кратных 3.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
