Вопрос задан 24.07.2023 в 11:35.
Предмет Информатика.
Спрашивает Степанов Степан.
В паскале, найти последнюю букву в слове (составить программу)
Ответы на вопрос
Отвечает Трусов Даниил.
Программа для вывода последнего символа (буквы) в ведённой строке.
var s:string;
begin
readln(s); {Ввод слова}
writeln(s[s.Length]); {Вывод последнего символа в ведённой строке}
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Чтобы написать программу на языке Паскаль для нахождения последней буквы в слове, следуйте этим шагам:
- Запросите у пользователя ввод слова.
- Найдите длину слова.
- Получите последний символ слова, используя его длину.
Вот пример программы на языке Паскаль:
pascalprogram FindLastLetter; var word: string; lastLetter: char; begin // Введите слово write('Введите слово: '); readln(word); // Получите длину слова if Length(word) > 0 then begin // Получите последний символ слова lastLetter := word[Length(word)]; // Выведите последнюю букву writeln('Последняя буква в слове: ', lastLetter); end else writeln('Слово пустое.'); end.
Программа запрашивает у пользователя ввести слово, затем находит последний символ этого слова и выводит его на экран. Обратите внимание, что в Pascal индексация строк начинается с 1, поэтому мы используем Length(word) для получения длины слова и word[Length(word)] для получения последнего символа.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
