Вопрос задан 24.07.2023 в 08:41. Предмет Информатика. Спрашивает Елфимчев Артур.

Написать программу! С++ ДАЮ 35б СРОЧНО! ПОЖАЛУЙСТА!! Дана последовательность чисел от -а до b не

включая 0. Нужно выводить каждый третий элемент последовательной каждый на новой строке.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Самохина Алина.

#include <iostream>


using namespace std;


int main()

{

   int a = -16;

   int b = 15;

   for (int i = a; i <= b; i += (i>=-3 && i<0)?4:3){

       cout << i << "\n";

   }

   return 0;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Хорошо, вот C++ программа, которая решает вашу задачу:

cpp
#include <iostream> int main() { int a, b; std::cout << "Введите значение a: "; std::cin >> a; std::cout << "Введите значение b: "; std::cin >> b; if (a >= 0 || b <= 0) { std::cout << "Последовательность чисел должна быть от -а до b и не содержать 0." << std::endl; return 1; } for (int i = a; i < b; i += 3) { std::cout << i << std::endl; } return 0; }

Программа запрашивает у пользователя значения a и b, а затем выводит каждый третий элемент последовательности от a до b (не включая 0) на новой строке. Убедитесь, что вводите правильные значения для a и b, чтобы последовательность не содержала 0 и удовлетворяла условию задачи.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос