Вопрос задан 24.07.2023 в 01:22.
Предмет Информатика.
Спрашивает Кузнецов Илья.
Напишите программу которая вычисляет нечетность числа (Pascal)
Ответы на вопрос
Отвечает Тушин Михаил.
var
x,y: integer;
begin
write('Введите 2 числа через пробел: ');
readln(x,y);
if (x mod 2<>0)and(y mod 2<>0)
then write('Да')
else write('Нет');
readln;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот простая программа на языке Pascal, которая вычисляет нечетность числа:
pascalprogram CheckOddness; var num: integer; begin // Ввод числа с клавиатуры writeln('Введите число: '); readln(num); // Проверка нечетности числа if num mod 2 = 1 then writeln('Число ', num, ' является нечетным.') else writeln('Число ', num, ' является четным.'); // Ожидание ввода перед выходом readln; end.
Программа сначала запрашивает ввод числа с клавиатуры. Затем она проверяет остаток от деления этого числа на 2 с помощью оператора mod. Если остаток равен 1, то число является нечетным, и программа выводит соответствующее сообщение. В противном случае, если остаток равен 0, число считается четным.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 312
Информатика 23
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
