Вопрос задан 23.07.2023 в 03:17. Предмет Информатика. Спрашивает Кот Настя.

ПОМОГИТЕ ПОЖАЛУЙСТА!!! Паскаль АБС 1.Символы вводятся с клавиатуры до символа ‘.’ (точка).

Вывести символы, предшествующие каждому из введенных. (Ввод: feui56HG Вывод: edth45GF)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Трохименко Никита.

var k:char;

s:string;

BEGIN

s:='';

repeat

read(k);

s:=s+chr(ord(k)-1)

until k='.';

delete(s,pos('-',s),1);

writeln(s);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Хорошо, чтобы решить данную задачу, вам потребуется написать программу на языке программирования Паскаль. Вот пример кода, который решает данную задачу:

pascal
program SymbolsBeforeDot; var ch: char; begin write('Введите символы с клавиатуры (до символа "."): '); read(ch); while ch <> '.' do begin // Проверяем, является ли введенный символ буквой или цифрой if (ch >= 'a') and (ch <= 'z') then begin // Выводим предыдущую букву, предшествующую текущей write(chr(ord(ch) - 1)); end else if (ch >= 'A') and (ch <= 'Z') then begin // Выводим предыдущую букву в верхнем регистре, предшествующую текущей write(chr(ord(ch) - 1)); end else if (ch >= '0') and (ch <= '9') then begin // Выводим предыдущую цифру, предшествующую текущей write(chr(ord(ch) - 1)); end else begin // Выводим символ без изменений, если это не буква и не цифра write(ch); end; // Считываем следующий символ read(ch); end; writeln; // Переход на новую строку после вывода всех символов end.

Пожалуйста, убедитесь, что ваш компилятор поддерживает стандарт языка Pascal, в котором используется функция chr, а также что он настроен на чтение символов с клавиатуры и вывод на экран.

Вы можете скопировать данный код в среду разработки Pascal (например, Lazarus) и запустить программу. После запуска введите символы с клавиатуры и завершите ввод символом "." (точка). Программа выведет символы, предшествующие каждому из введенных, согласно указанной вами логике.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос