Ребят,хелп,умоляю.. Написать программу для подсчёта количества чётных и нечётных цифр любого
числа( в паскале)пожалуйста, очень срочно.плизОтветы на вопрос
var
a, chet, nechet : integer;
begin
write('введите число: ');
readln(a);
while a > 0 do begin
if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;
a := a div 10;
end;
writeln('четных: ', chet);
writeln('не четных: ', nechet);
end.
программа считает 0 как четное число. Если нужно что бы 0 не учитывался при подсчете то необходимо строку:
if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;
заменить на:
if a mod 10 <> 0 then if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;
Конечно, я помогу вам написать программу для подсчета количества четных и нечетных цифр любого числа на языке Паскаль. Вот пример программы:
pascalprogram CountEvenOddDigits; var number, digit, evenCount, oddCount: integer; begin evenCount := 0; oddCount := 0; // Введите число, для которого нужно подсчитать четные и нечетные цифры write('Введите число: '); readln(number); // Перебираем цифры числа, пока число не станет равным нулю while number <> 0 do begin // Получаем последнюю цифру числа digit := number mod 10; // Проверяем, является ли цифра четной или нечетной if digit mod 2 = 0 then evenCount := evenCount + 1 else oddCount := oddCount + 1; // Убираем последнюю цифру числа, делая целочисленное деление на 10 number := number div 10; end; writeln('Количество четных цифр: ', evenCount); writeln('Количество нечетных цифр: ', oddCount); end.
Программа просит вас ввести число, после чего она перебирает его цифры и подсчитывает количество четных и нечетных цифр. Затем выводит результаты.
Надеюсь, это поможет! Если у вас возникнут дополнительные вопросы, не стесняйтесь спрашивать. Удачи вам!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
