Дан массив чисел. Определить каких чисел больше четных или нечетных. Введите массив целых чисел из
15 элементов: 8,15,17,10,5,2,87,33,28,99,14,75,13,25,64 Нечетных чисел больше чем четных программа:Pascal Пожалуйста!!!!!Ответы на вопрос
var a:array [1..15] of integer;
i,k:integer;
BEGIN
k:=0;
writeln('Введите числа');
for i:=1 to 15 do begin
read(a[i]);
if (a[i] mod 2=0) then k:=k+1;
end;
if k<8 then
writeln('Нечетных чисел больше, чем четных.') else
writeln('Четных чисел больше, чем нечетных.');
end.
Без массива:
Program n_1;
var a, b, i, n: integer;
begin
a:=0; b:=0;
for i:=1 to 15 do begin
read(n);
if n mod 2 = 1 then a:=a+1
else b:=b+1;
end;
if a>b then writeln('Нечетных чисел больше, чем четных')
else writeln('Четных чисел больше, чем нечетных');
end.
С массивом:
Program n_1;
var a, b, i: integer; n: array [1..15] of integer;
begin
a:=0; b:=0;
for i:=1 to 15 do begin
read(n[i]);
if n[i] mod 2 = 1 then a:=a+1
else b:=b+1;
end;
if a>b then writeln('Нечетных чисел больше, чем четных')
else writeln('Четных чисел больше, чем нечетных');
end.
Но честно, не вижу смысла использовать массив.
Для определения того, сколько чисел четных и нечетных в данном массиве целых чисел, вам потребуется написать программу на языке Pascal. Вот пример программы, которая решит вашу задачу:
pascalprogram CountEvenOdd; const SIZE = 15; var numbers: array[1..SIZE] of Integer; evenCount, oddCount, i: Integer; begin evenCount := 0; oddCount := 0; writeln('Введите массив целых чисел из 15 элементов:'); for i := 1 to SIZE do begin read(numbers[i]); if numbers[i] mod 2 = 0 then evenCount := evenCount + 1 else oddCount := oddCount + 1; end; writeln('Количество четных чисел: ', evenCount); writeln('Количество нечетных чисел: ', oddCount); if evenCount > oddCount then writeln('Четных чисел больше чем нечетных.') else if evenCount < oddCount then writeln('Нечетных чисел больше чем четных.') else writeln('Четных и нечетных чисел поровну.'); end.
Скопируйте этот код в среду программирования на Pascal (например, Lazarus) и запустите программу. После ввода массива чисел, она выведет количество четных и нечетных чисел, а также сообщит, каких чисел больше.
Ваш массив: 8, 15, 17, 10, 5, 2, 87, 33, 28, 99, 14, 75, 13, 25, 64
Вывод программы для этого массива:
Количество четных чисел: 5 Количество нечетных чисел: 10 Нечетных чисел больше чем четных.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
