Вопрос задан 22.07.2023 в 09:55.
Предмет Информатика.
Спрашивает Кислова Снежана.
Напишите программу на языке Pascal. 1. Напишите программу. определяющую, сколько раз в число входит
цифра. Цифра и число задаются пользователем в начале работы программы. 2. Напишите программу, определяющую, равна ли первая цифра числа его последней цифре. 3. Запишите алгоритм подсчета суммы, количества и произведения цифр произвольного целого положительного числа.Ответы на вопрос
Отвечает Чистякова Валерия.
1:
var N,k,s:integer;
BEGIN
s:=0;
readln(N,k);
N:=abs(N);
while N>0 do begin
if (N mod 10=k) then
s:=s+1;
N:=N div 10;
end;
writeln(s);
end.
2:
var N:integer;
s:string;
BEGIN
readln(N);
s:=IntToStr(N);
if (s[1]=s[Length(s)]) then
writeln('ДА') else
writeln('НЕТ');
end.
3:
var N,p,s,k:integer;
BEGIN
readln(N);
p:=1;
s:=0;
k:=0;
while N>0 do begin
p:=p*(N mod 10);
s:=s+(N mod 10);
k:=k+1;
N:=N div 10;
end;
writeln('Количество цифр = ',k);
writeln('Сумма цифр = ',s);
writeln('Произведение цифр = ',p);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот решения трех задач на языке Pascal:
- Программа для определения, сколько раз в число входит цифра:
pascalprogram CountDigitOccurrences; var number, digitToFind, count: integer; numAsString: string; i: integer; begin writeln('Введите число:'); readln(number); writeln('Введите цифру, которую нужно найти:'); readln(digitToFind); numAsString := IntToStr(number); count := 0; for i := 1 to length(numAsString) do begin if StrToInt(numAsString[i]) = digitToFind then count := count + 1; end; writeln('Цифра ', digitToFind, ' встречается в числе ', number, ' ', count, ' раз(а).'); end.
- Программа для определения, равна ли первая цифра числа его последней цифре:
pascalprogram FirstDigitEqualsLastDigit; var number, firstDigit, lastDigit: integer; numAsString: string; begin writeln('Введите число:'); readln(number); numAsString := IntToStr(number); firstDigit := StrToInt(numAsString[1]); lastDigit := StrToInt(numAsString[length(numAsString)]); if firstDigit = lastDigit then writeln('Первая цифра числа равна последней цифре.') else writeln('Первая цифра числа не равна последней цифре.'); end.
- Программа для подсчета суммы, количества и произведения цифр произвольного целого положительного числа:
pascalprogram SumCountProductDigits; var number, digit, sum, count, product: integer; numAsString: string; i: integer; begin writeln('Введите число:'); readln(number); numAsString := IntToStr(number); sum := 0; count := 0; product := 1; for i := 1 to length(numAsString) do begin digit := StrToInt(numAsString[i]); sum := sum + digit; product := product * digit; count := count + 1; end; writeln('Сумма цифр числа: ', sum); writeln('Количество цифр в числе: ', count); writeln('Произведение цифр числа: ', product); end.
Для каждой программы пользователь будет приглашен ввести необходимые данные, и результат будет отображен на экране.
Похожие вопросы
Информатика 47
Информатика 39
Информатика 44
Информатика 81
Информатика 98
Информатика 23
Информатика 28
Информатика 40
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
