Составить программу в PascalABC расчета площади,углов треугольника,если все стороны известны.Точка
A имеет координаты (0 , 0)Ответы на вопрос
var x1,x2,x3,y1,y2,y3:integer;
S:real;
begin
writeln('Введите координату точки x1 ,y1 ' );
readln(x1, y1);
writeln('Введите координату точки x2 ,y2 ');
readln(x2, y2);
writeln('Введите координату точки x3 ,y3 ');
readln(x3, y3);
S:=abs(0.5*((x1-x3)*(y2-y3)-(x2-x3)*(y1-y3)));
writeln('Площадь S= ',S:3:0);
end.
Для расчета площади и углов треугольника, если известны координаты всех трех вершин, воспользуемся формулой для площади треугольника и теоремой косинусов для вычисления углов. В данном случае, так как точка A имеет координаты (0, 0), значит, она будет одной из вершин треугольника. Пусть B и C - координаты остальных двух вершин.
Вот программа на PascalABC, которая выполняет данные расчеты:
pascalprogram TriangleAreaAndAngles; var Ax, Ay, Bx, By, Cx, Cy: real; // Координаты точек A, B и C AB, AC, BC: real; // Длины сторон треугольника Area: real; // Площадь треугольника AngleA, AngleB, AngleC: real; // Углы треугольника в радианах begin { Ввод координат точек B и C } writeln('Введите координаты точки B:'); write('Bx = '); readln(Bx); write('By = '); readln(By); write('Введите координаты точки C:'); write('Cx = '); readln(Cx); write('Cy = '); readln(Cy); { Расчет длин сторон треугольника } AB := sqrt((Bx - 0) * (Bx - 0) + (By - 0) * (By - 0)); // Расстояние от A до B AC := sqrt((Cx - 0) * (Cx - 0) + (Cy - 0) * (Cy - 0)); // Расстояние от A до C BC := sqrt((Cx - Bx) * (Cx - Bx) + (Cy - By) * (Cy - By)); // Расстояние от B до C { Расчет площади треугольника по формуле Герона } Area := sqrt((AB + AC + BC) * (AB + AC - BC) * (AB - AC + BC) * (-AB + AC + BC)) / 4; { Расчет углов треугольника в радианах по теореме косинусов } AngleA := arccos((AB * AB + AC * AC - BC * BC) / (2 * AB * AC)); AngleB := arccos((AB * AB + BC * BC - AC * AC) / (2 * AB * BC)); AngleC := arccos((AC * AC + BC * BC - AB * AB) / (2 * AC * BC)); { Перевод углов в градусы } AngleA := AngleA * 180 / pi; AngleB := AngleB * 180 / pi; AngleC := AngleC * 180 / pi; { Вывод результатов } writeln('Площадь треугольника: ', Area:0:2); writeln('Угол A: ', AngleA:0:2, ' градусов'); writeln('Угол B: ', AngleB:0:2, ' градусов'); writeln('Угол C: ', AngleC:0:2, ' градусов'); end.
Программа запрашивает координаты точек B и C, а затем вычисляет площадь треугольника и углы A, B и C в градусах, используя формулу Герона и теорему косинусов.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
