Написать программу на Паскале, используя цикл: 1) Посчитать сумму четных чисел, меньших или
равных n S = 2 + 4 + 6 + … + n 2. Найти сумму нечётных цифр числа 3. Возвести число в степень.Ответы на вопрос
Ответ:
Объяснение:
// Возведение в степень
program stepen;
var
p,i,n, a:integer;
begin
write('введите число и степень');
readln(a,n);
p:=1;
for i:=1 to n do p:=p*a;
writeln('Число ',a, ' в степени ',n,' = ',p);
readln;
end.
//Сумма нечетных цифр числа
program project1;
var
a, b, s : integer;
begin
s := 0;
write('введите число: ');
readln(a);
while a <> 0 do
begin
b := a mod 10;
if b mod 2 <> 0 then s := s + b;
a := a div 10
end;
writeln('сумма нечетных цифр: ', s);
readln;
end.
//Сумма четных чисел до n
program summach;
var
S,n,i:integer;
begin
Write('Введите n=');
readln(n);
if n mod 2<>0 then n:=n-1;
n:=n div 2;
s:=0;
for i:=1 to n do
s:=s+2*i;
writeln('s=',s);
readln;
end.
//===================================
// сумма четных с циклом repeat
program summach1;
Write('Введите n=');
readln(n);
if n mod 2<>0 then n:=n-1;
s:=0;i:=1;
repeat
s:=s+2*i;
i:=i+1;
until 2*i>n ;
writeln('n=',n);
writeln('s=',s);
readln;
Для написания программы на Паскале, реализующей эти три задачи, нужно объявить переменные, использовать циклы и условия. Вот программа, которая выполняет описанные задачи:
pascalprogram SumEvenNumbersAndOddDigits; var n, i, S, num, digit, powerResult: Integer; begin // Задача 1: Посчитать сумму четных чисел, меньших или равных n Write('Введите число n: '); ReadLn(n); S := 0; for i := 2 to n step 2 do begin S := S + i; end; WriteLn('Сумма четных чисел от 2 до ', n, ' равна: ', S); // Задача 2: Найти сумму нечетных цифр числа 3 Write('Введите число для анализа: '); ReadLn(num); S := 0; while num > 0 do begin digit := num mod 10; if digit mod 2 = 1 then begin S := S + digit; end; num := num div 10; end; WriteLn('Сумма нечетных цифр числа равна: ', S); // Задача 3: Возвести число в степень Write('Введите число: '); ReadLn(num); Write('Введите степень: '); ReadLn(powerResult); S := 1; for i := 1 to powerResult do begin S := S * num; end; WriteLn(num, ' в степени ', powerResult, ' равно: ', S); end.
Программа позволяет пользователю ввести число n для первой задачи и число num для второй задачи, а также степень powerResult для третьей задачи. После ввода, программа вычислит и выведет результаты каждой задачи.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
