Вопрос задан 20.07.2023 в 15:26.
Предмет Информатика.
Спрашивает Кособокова Настя.
ЯЗЫК JAVA! Пожалуйста, помогите написать программу! 2. Напишите класс, который принимает с
клавиатуры два целых числа и, если первое больше второго, выводит на экран их сумму, если же наоборот – выводит на экран их произведение. В случае же, если числа одинаковы, программа выводит на экран сообщение Числа равны.Ответы на вопрос
Отвечает Груздева Саша.
Код находится в приложении.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, помогу вам написать программу на языке Java. Вот пример кода, который решает вашу задачу:
javaimport java.util.Scanner;
public class CompareNumbers {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
System.out.print("Введите первое целое число: ");
int firstNumber = scanner.nextInt();
System.out.print("Введите второе целое число: ");
int secondNumber = scanner.nextInt();
if (firstNumber > secondNumber) {
int sum = firstNumber + secondNumber;
System.out.println("Сумма чисел: " + sum);
} else if (firstNumber < secondNumber) {
int product = firstNumber * secondNumber;
System.out.println("Произведение чисел: " + product);
} else {
System.out.println("Числа равны.");
}
scanner.close();
}
}
Скопируйте этот код в файл с расширением .java, например, CompareNumbers.java. Затем скомпилируйте программу, выполнив команду javac CompareNumbers.java в командной строке. После успешной компиляции запустите программу, выполнив команду java CompareNumbers.
Теперь программа будет ожидать ввода двух целых чисел с клавиатуры и выведет результат в соответствии с вашими условиями.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
