Программу требуется написать на языке Pascal: Массив нужно заполнить вводом с клавиатурыДан
целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 100. Составьте программу, которая находит и выводит произведение двузначных элементов массива, которые не делятся на 6. Гарантируется, что в исходном массиве есть хотя бы один такой элемент.Ответы на вопрос
program raf105;
var a:array[1..30] of integer;
pro,i:integer;
begin
writeln('Вводите 30 чисел по очереди');
pro:=1;
for i:=1 to 30 do
begin
readln(a[i]);
if (a[i] <= 99) and (a[i] >= 10) and ((a[i] mod 6) <> 0)
then pro*= a[i];
end;
writeln('Вывод: ',pro);
end.
Для решения данной задачи на языке Pascal, нужно сначала объявить массив, заполнить его значениями с помощью ввода с клавиатуры, а затем выполнить требуемые операции по нахождению произведения двузначных элементов, не делящихся на 6. Ниже представлен пример кода для решения этой задачи:
pascalprogram TwoDigitMultiplication; const N = 30; // Размер массива var arr: array[1..N] of integer; i, product: integer; begin // Ввод массива с клавиатуры writeln('Введите ', N, ' целочисленных элементов массива (от 0 до 100):'); for i := 1 to N do begin repeat write('Элемент ', i, ': '); readln(arr[i]); until (arr[i] >= 0) and (arr[i] <= 100); end; // Поиск произведения двузначных элементов, не делящихся на 6 product := 1; for i := 1 to N do begin if (arr[i] >= 10) and (arr[i] <= 99) and (arr[i] mod 6 <> 0) then product := product * arr[i]; end; // Вывод результата writeln('Произведение двузначных элементов, не делящихся на 6: ', product); end.
В этой программе мы объявляем массив arr с помощью константы N, заполняем его значениями, проверяем условия нахождения двузначных элементов, не делящихся на 6, и выводим произведение этих элементов.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
