Вопрос задан 19.07.2023 в 19:56. Предмет Информатика. Спрашивает Суворова Александра.

Нужна помощь срочно!! Напишите программу в Паскаль! Задумано трёхзначное число, которое при

делении на 15 даёт в остатке 11, а при делении на 11 даёт в остатке 9. Напишите программу, которая находит все такие числа.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Котикова Виктория.

Ответ:

for i in range(999):

     if i%15==11 and i%11==9:

            print(i)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на языке Паскаль, которая находит все трехзначные числа, удовлетворяющие условиям:

pascal
program FindNumbers; var num: integer; begin writeln('Трёхзначные числа, которые при делении на 15 дают остаток 11 и при делении на 11 дают остаток 9:'); for num := 100 to 999 do begin if (num mod 15 = 11) and (num mod 11 = 9) then writeln(num); end; end.

Программа перебирает все трехзначные числа от 100 до 999 и проверяет условия с помощью оператора if. Если число удовлетворяет обоим условиям, оно выводится на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос