Вопрос задан 19.07.2023 в 15:08.
Предмет Информатика.
Спрашивает Чернобай Валерия.
Срочно! Даю 40 баллов Напишите программу в паскале с оператором repeatДано целое число N (>0)
используя операции деления нацело и взятия остатка от деления, найти количество и сумму его цифр (N=63)Ответы на вопрос
Отвечает Кубик Дима.
program raf105;
var abc,a,sum,count: integer;
begin
write('Введите число: ');
readln(abc);
count:= -1;
repeat
a:= abc mod 10;
sum:= sum+a;
count:= count+1;
abc:= abc div 10;
until a=0;
writeln('Сумма цифр: ',sum);
writeln('Количество цифр: ',count);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Хорошо, вот программа на языке Паскаль для вычисления количества и суммы цифр целого числа N:
pascalprogram SumAndCountDigits; var N, num, digit, count, sum: integer; begin writeln('Введите целое число N (>0): '); readln(N); num := N; count := 0; sum := 0; repeat digit := num mod 10; // Получаем последнюю цифру числа sum := sum + digit; // Добавляем её к общей сумме count := count + 1; // Увеличиваем счётчик цифр num := num div 10; // Удаляем последнюю цифру числа until num = 0; writeln('Количество цифр в числе N: ', count); writeln('Сумма цифр числа N: ', sum); end.
Программа запрашивает у пользователя целое число N и затем с помощью операций деления нацело и взятия остатка от деления находит количество и сумму его цифр. Запустите программу в среде разработки Паскаля, и она выведет результат для числа N=63.
Похожие вопросы
Информатика 76
Информатика 93
Информатика 41
Информатика 142
Информатика 220
Информатика 62
Информатика 20
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
