Дан массив D(n). Найти минимальный среди элементов, больших суммы,и найти количество элементов, не
равных максимальному. Написать программу в Паскале,пожалуйста)Ответы на вопрос
program raf105;
const
n = 10;
var
d:array[1..n] of integer;
min,max,sum,notmax,i: integer;
begin
max:= -10000;
min:= 10000;
writeln('Заполните массив');
for i:=1 to n do
begin
readln(d[i]);
sum+= d[i];
if max<d[i]
then max:= d[i];
end;
for i:=1 to n do
begin
if d[i]<>max
then notmax+= 1;
if (d[i]>sum) and (d[i]<min)
then min:= d[i];
end;
if min<>10000
then writeln('Минимальный среди элементов, больших суммы: ',min)
else writeln('Минимальный среди элементов, больших суммы: Не найдено');
writeln('Количество элементов, не равных максимальному: ',notmax);
end.
Язык PascalABC
Для решения данной задачи нахождения минимального элемента, большего суммы, и подсчета количества элементов, не равных максимальному, можно написать программу на языке Паскаль. Ниже представлен код программы:
pascalprogram MinMaxElements; const n = 10; // Задайте размер массива здесь type TArray = array[1..n] of Integer; var D: TArray; i, sum, maxElement, minGreaterThanSum, countNotMax: Integer; begin // Ввод массива D(n) writeln('Введите элементы массива D:'); for i := 1 to n do readln(D[i]); // Инициализация переменных sum := 0; maxElement := D[1]; minGreaterThanSum := MaxInt; countNotMax := 0; // Находим сумму элементов и максимальный элемент for i := 1 to n do begin sum := sum + D[i]; if D[i] > maxElement then maxElement := D[i]; end; // Находим минимальный элемент, больший суммы, и считаем количество элементов, не равных максимальному for i := 1 to n do begin if (D[i] > sum) and (D[i] < minGreaterThanSum) then minGreaterThanSum := D[i]; if D[i] <> maxElement then countNotMax := countNotMax + 1; end; // Вывод результатов writeln('Минимальный элемент, больший суммы: ', minGreaterThanSum); writeln('Количество элементов, не равных максимальному: ', countNotMax); end.
Пожалуйста, убедитесь, что размер массива n соответствует вашему вводу данных. Программа запрашивает ввод элементов массива D, затем находит минимальный элемент, больший суммы, и подсчитывает количество элементов, не равных максимальному.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
