 
С++ помогите ❤️ Напишите программу, заполняющую двухмерный массив размерностью 10 на 10 целыми
числами по возрастанию. 0
        0
         0
        0
    Ответы на вопрос
 
        Ответ:
#include <iostream>
#include <time.h>
#include <iomanip>
using namespace std;
int main()
{
int a[10][10];
int i, j, n;
setlocale(LC_ALL, "Russian");
srand(time(NULL));
n = 1;
for (i = 0; i < 10; i++) {
cout << "\n";
for (j = 0; j < 10; j++) {
n += (double)rand() / (RAND_MAX + 1) * 5;
a[i][j] = n;
cout << setw(5) << a[i][j] << " ";
}
}
}
 0
                    0
                     0
                    0
                 
            Конечно, я помогу вам написать программу на C++, которая заполнит двухмерный массив размером 10 на 10 целыми числами по возрастанию. Для этого можно использовать два вложенных цикла, чтобы перебрать все элементы массива и заполнить их значениями по возрастанию.
Вот программа:
cpp#include <iostream>
int main() {
    const int rows = 10;
    const int cols = 10;
    int array[rows][cols];
    int count = 1;
    // Заполняем массив значениями по возрастанию
    for (int i = 0; i < rows; i++) {
        for (int j = 0; j < cols; j++) {
            array[i][j] = count++;
        }
    }
    // Выводим массив на экран
    std::cout << "Двухмерный массив 10x10 по возрастанию:\n";
    for (int i = 0; i < rows; i++) {
        for (int j = 0; j < cols; j++) {
            std::cout << array[i][j] << "\t";
        }
        std::cout << std::endl;
    }
    return 0;
}
Эта программа создает двухмерный массив размером 10 на 10 и заполняет его целыми числами от 1 до 100 по возрастанию. Затем она выводит массив на экран, разделяя элементы табуляцией для наглядности.
После выполнения программы, вы увидите двухмерный массив 10x10 с числами, идущими по возрастанию от 1 до 100.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			