Вопрос задан 17.07.2023 в 11:28. Предмет Информатика. Спрашивает Сермягин Илья.

составьте программу вычисления в массиве из 10 элементов введенных с клавиатуры произведения всех

чисел кратных 7
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сажнева Мария.

Ответ:

Объяснение:

a = list(map(int, input().split()))

pr = 1

for i in a:

 if i % 7 == 0:

   pr *= i

print(pr)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая позволяет вам вычислить произведение всех чисел, кратных 7, в массиве из 10 элементов, введенных с клавиатуры:

python
# Создаем пустой массив размером 10 numbers = [0] * 10 # Вводим числа с клавиатуры и сохраняем их в массиве for i in range(10): numbers[i] = int(input(f"Введите число {i+1}: ")) # Инициализируем переменную для хранения произведения product = 1 # Вычисляем произведение всех чисел, кратных 7 for num in numbers: if num % 7 == 0: # Проверяем, кратно ли число 7 product *= num # Выводим результат print("Произведение чисел, кратных 7:", product)

Эта программа позволит вам ввести 10 чисел с клавиатуры и сохранить их в массиве. Затем она проверит каждое число на кратность 7 и умножит его на переменную product. В конце программа выведет произведение всех чисел, кратных 7.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос