Написать программу (Паскаль) В массиве хранится информация о стоимости 1 кг 20 видов конфет.
Определить, сколько стоят самые дешёвые конфеты . Если таких несколько, то должен быть найден индекс первого из них .Ответы на вопрос
program test;
var a:array [1..20] of integer;
min, i, imin: integer;
begin
min:=a[19];
imin:=19;
for i:=1 to 20 do begin
a[i]:=random (151)+150;
write (a[i]:4);
end;
writeln;
for i:=19 downto 1 do begin
if a[i]<min then begin imin:=i; min:=a[i]; end;
end;
write (imin);
writeln;
write (a[imin]);
end.
Вот пример программы на языке Паскаль, которая находит самые дешевые конфеты и выводит их стоимость и индекс первой из них:
pascalprogram FindCheapestCandy; const N = 20; // количество видов конфет var prices: array[1..N] of real; // массив с информацией о стоимости конфет i, cheapestIndex: integer; cheapestPrice: real; begin // Ввод стоимости конфет writeln('Введите стоимость 20 видов конфет:'); for i := 1 to N do begin write('Конфета ', i, ': '); readln(prices[i]); end; // Поиск самых дешевых конфет cheapestPrice := prices[1]; cheapestIndex := 1; for i := 2 to N do begin if prices[i] < cheapestPrice then begin cheapestPrice := prices[i]; cheapestIndex := i; end; end; // Вывод результатов writeln('Самые дешёвые конфеты:'); writeln('Индекс первой конфеты: ', cheapestIndex); writeln('Стоимость: ', cheapestPrice:0:2, ' рублей'); end.
Программа сначала запрашивает у пользователя стоимость 20 видов конфет. Затем она проходит по массиву стоимостей и находит самые дешевые конфеты, запоминая их стоимость и индекс первой из них. В конце программа выводит найденную информацию на экран.
Обратите внимание, что в этом примере используется массив prices типа real, чтобы хранить стоимость конфет. Вы можете изменить тип массива, в зависимости от ваших требований.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
