Вопрос задан 17.07.2023 в 07:42. Предмет Информатика. Спрашивает Юртаева Дарья.

Помогите с составлением программы на языке паскаль. Условие: Составьте программу нахождения

корней квадратного уравнения ax²+bx+c=0,заданного своими коэффициентами a,b,c.Корни квадратного уравнения находятся по формуле x₁,₂=-b±√D/2a.Где дискриминант D=b²-4ac. P.S Заранее спасибо.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Снегирёв Владислав.

var a,b,c,D: real;

begin

writeln('программа решения квадратного уравнения ax^2+bx+c=0');

write('a=');

readln(a);

write('b=');

readln(b);

write('c=');

readln(c);

D:=b*b-4*a*c;

if a=0 then write('a=0 => уравнение вырождается в линейное => x=-c/b=',-c/b)  

else if D>0 then begin

writeln('x1=',(-b+sqrt(D))/(2*a));

writeln('x2=',(-b-sqrt(D))/(2*a));

end else if D=0 then writeln('x1=x2=',-b/(2*a))

else writeln('уравнение не имеет действительных корней');

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам с составлением программы на языке Паскаль для нахождения корней квадратного уравнения. Вот пример программы, учитывающей условия, которые вы указали:

pascal
program Нахождение_корней_квадратного_уравнения; var a, b, c, D, x1, x2: real; begin writeln('Введите коэффициенты квадратного уравнения:'); write('a: '); readln(a); write('b: '); readln(b); write('c: '); readln(c); D := b * b - 4 * a * c; if D > 0 then begin x1 := (-b + sqrt(D)) / (2 * a); x2 := (-b - sqrt(D)) / (2 * a); writeln('Уравнение имеет два различных корня:'); writeln('x1 = ', x1:0:2); writeln('x2 = ', x2:0:2); end else if D = 0 then begin x1 := -b / (2 * a); writeln('Уравнение имеет один корень:'); writeln('x = ', x1:0:2); end else begin writeln('Уравнение не имеет действительных корней.'); end; readln; end.

Вы можете вставить эту программу в среду разработки Паскаль и запустить ее. После ввода коэффициентов a, b и c программа вычислит дискриминант D и определит количество и значения корней квадратного уравнения.

Обратите внимание, что данная программа предназначена для работы с вещественными числами (real). Если вам нужно работать только с целыми числами, замените real на integer, и используйте целочисленные операции при вычислении дискриминанта и корней.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос