Вопрос задан 16.07.2023 в 15:12.
Предмет Информатика.
Спрашивает Лукьяненкова Алёнка.
На вход программе подаётся n натуральных чисел. Найти среднее арифметическое двухзначных чисел
кратных трём. В языке C++ с решением пожалуйста!Ответы на вопрос
Отвечает Хасаншина Екатерина.
Ответ:
#include <iostream>
using namespace std;
int main() {
int n, y = 0, x, g = 0;
cin >> n;
for (int i = 0; i < n; i++) {
cin >> x;
if (x >= 10 and x <= 99 and x % 3 == 0) {
g += x;
y++;
}
}
cout << g / y;
}
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример решения задачи на C++:
cpp#include <iostream>
int main() {
int n;
std::cout << "Введите количество чисел: ";
std::cin >> n;
int count = 0; // счетчик двузначных чисел, кратных трём
int sum = 0; // сумма двузначных чисел, кратных трём
for (int i = 0; i < n; i++) {
int num;
std::cout << "Введите число: ";
std::cin >> num;
if (num >= 10 && num <= 99 && num % 3 == 0) {
count++;
sum += num;
}
}
if (count > 0) {
double average = static_cast<double>(sum) / count;
std::cout << "Среднее арифметическое двузначных чисел, кратных трём: " << average << std::endl;
} else {
std::cout << "Нет двузначных чисел, кратных трём." << std::endl;
}
return 0;
}
В этом примере мы считываем количество чисел n, а затем в цикле запрашиваем сами числа от пользователя. Если число является двузначным и кратным трём, мы увеличиваем счетчик count и добавляем число к сумме sum. В конце вычисляем среднее арифметическое, если были найдены двузначные числа, кратные трём, и выводим его. Если таких чисел нет, выводим сообщение об этом.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
