Вопрос задан 18.06.2023 в 02:33. Предмет Информатика. Спрашивает Ляхов Дима.

«Списки в Python» №1.На вход программе подается одна строка, состоящая из слов на английском

языке, разделенных пробелами. Создайте из этой строки список слов, и выведите на экран первые две буквы каждого слова в столбец. №2.На вход программе подается одна строка, состоящая из слов на английском языке, разделенных пробелами. Создайте из этой строки список слов, и выведите на экран первые две буквы каждого слова в столбец. №3На вход программе подается одна строка – натуральные числа, разделенные пробелами. Отсортируйте список по возрастанию. Выведите результат на экран. Правда ли, что в списке максимальный и минимальный элемент оканчиваются одной цифрой?
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Коротков Виталик.

1)

s = str(input()).split()

for a in s:

   print(a[0] + a[1])

#нет проверки на то что длина слов больше 1

2)

условие то же что и в 1)

3)

s = list(map(int, str(input()).split()))

s.sort()

print(s)

if str(min(s))[len(str(min(s)))-1] == str(max(s))[len(str(max(s)))-1]:

   print('Правда')

else:

   print('Неправда')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

№1. Для решения данной задачи можно использовать метод split() для разделения строки на список слов. Затем можно использовать цикл for для обхода каждого слова в списке и вывести первые две буквы каждого слова в столбец. Пример кода:

```python string = input("Введите строку: ") words = string.split()

for word in words: print(word[:2]) ```

Пример работы программы: ``` Введите строку: hello world he wo ```

№2. Для решения данной задачи также можно использовать метод split() для разделения строки на список слов. Затем можно использовать цикл for для обхода каждого слова в списке и вывести первые две буквы каждого слова в столбец. Пример кода:

```python string = input("Введите строку: ") words = string.split()

for word in words: print(word[:2]) ```

Пример работы программы: ``` Введите строку: hello world he wo ```

№3. Для решения данной задачи можно использовать метод split() для разделения строки на список чисел. Затем можно использовать функцию sorted() для сортировки списка по возрастанию. Для проверки, оканчивается ли максимальный и минимальный элемент списка одной цифрой, можно использовать условные операторы и преобразование числа в строку для проверки последнего символа. Пример кода:

```python string = input("Введите строку: ") numbers = [int(num) for num in string.split()]

sorted_numbers = sorted(numbers)

print("Отсортированный список:", sorted_numbers)

max_number = sorted_numbers[-1] min_number = sorted_numbers[0]

if str(max_number)[-1] == str(min_number)[-1]: print("Максимальный и минимальный элемент оканчиваются одной цифрой") else: print("Максимальный и минимальный элемент не оканчиваются одной цифрой") ```

Пример работы программы: ``` Введите строку: 5 2 10 7 3 Отсортированный список: [2, 3, 5, 7, 10] Максимальный и минимальный элемент оканчиваются одной цифрой ```

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос