Вопрос задан 15.07.2023 в 06:10. Предмет Информатика. Спрашивает Кухлевская Дарья.

Срочно ПИТОН!!!!!!!!!!!!!!!!!! Входные данные На вход программы поступает сначала число N

(1<=N<=100), а затем N пар чисел. Первое число каждой пары – натуральное, не превышающее 30000. Второе число каждой пары – 0 или 1. Выходные данные Требуется найти пары, в которых второе число равно 1, а из всех таких пар выбрать ту, в которой первое число максимально (если таких пар несколько, выберите любую из них). Программа должна вывести номер выбранной пары. Если пар, у которых второе число равно 1, нет, то выведите -1. Примеры входные данные 3 30000 1 2 1 3 1 выходные данные 300 1 0 входные данные 4 25 1 70 1 100 0 3 1 выходные данные 235 0 1 5
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Борисова Дарья.

n = int(input())

number_max = 0

pair_order = -1

for iteration in range(1, n + 1):

   a, b = list(map(int, input().split()))

   if b == 1:

       if a > number_max:

           number_max = a

           pair_order = iteration

print(pair_order)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вам нужно прочитать входные данные, обработать их и вывести результат. Вот пример кода на Python, который решает данную задачу:

python
def find_max_pair_with_second_number_one(N, pairs): max_number = -1 max_index = -1 for i in range(N): first_number, second_number = pairs[i] if second_number == 1 and first_number > max_number: max_number = first_number max_index = i return max_index def main(): N = int(input()) # Читаем количество пар pairs = [] # Читаем N пар чисел и добавляем их в список pairs for _ in range(N): first, second = map(int, input().split()) pairs.append((first, second)) result = find_max_pair_with_second_number_one(N, pairs) print(result) if __name__ == "__main__": main()

Вы можете скопировать этот код в свою среду разработки на Python и запустить его. Программа сначала попросит ввести количество пар N, а затем N пар чисел (первое число и второе число). После ввода она выведет номер выбранной пары или -1, если пар с вторым числом равным 1 не найдено.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос