Помогите пожалуйста!!! Составить программу в Паскале для обработки массива из 15 чисел Х = (0;
1,25; –371; 0,5; –0,1; 1,2; –5; –172,3; 19783; –2,7; 43,51; 0; –0,02; 14,5; 123,7). Найти наименьший элемент и его номер. В отчет включить программный код и результат работы программы.Ответы на вопрос
Ответ:
program Project1;
const
n = 15;
var
c: array[1..n] of real = (0, 1.25, -371, 0.5, -0.1, 1.2, -5, -172.3, 19783, -2.7, 43.51, 0, -0.02, 14.5, 123.7);
// Переменная для хранения массива.
i: integer; // Вспомогательная переменная для организации цикла.
minelem: real; // Переменная для хранения значения элемента с минимальным значением.
indmin: integer; // Переменная для хранения значения индекса минимального элемента.
begin
writeln('Исходный массив:');
for i:= 1 to n do // Вывод массива в консоль.
begin
write(c[i]:9:2);
if i mod 8 = 0 then
writeln;
end;
writeln;
minelem:= c[1];
indmin:= 1;
for i:= 2 to n do
if c[i] < minelem then // Условие для нахождения элемента с минимальным значением.
begin
minelem:= c[i];
indmin:= i; // Индекс элемента с минимальным значением.
end;
writeln('Минимальный элемент массива находится на ',indmin,' месте и равен ',minelem:0:2);
Readln;
end.
Объяснение:
В принципе я указал комментарии к некоторым действиям, так что должно быть понятно(комментарии потом лучше стереть). В отчет можешь сделать скриншот уже с результатом работы программы (мы так обычно делаем). Если остались вопросы пиши в комментарии.
===== PascalABC.NET =====
begin
var x := Arr(0.0, 1.25, -371.0, 0.5, -0.1, 1.2, -5.0, -172.3,
19783.0, -2.7, 43.51, 0.0, -0.02, 14.5, 123.7);
var im := x.IndexMin;
Write('Минимальный элемент номер ', im + 1, ' равен ', x[im])
end.

Конечно, я помогу вам составить программу на языке Паскаль для поиска наименьшего элемента и его номера в массиве. Вот код программы:
pascalprogram FindMinElement; const N = 15; type TArray = array[1..N] of Real; var X: TArray; i, minIndex: Integer; minValue: Real; begin { Заполнение массива } X[1] := 0; X[2] := 1.25; X[3] := -371; X[4] := 0.5; X[5] := -0.1; X[6] := 1.2; X[7] := -5; X[8] := -172.3; X[9] := 19783; X[10] := -2.7; X[11] := 43.51; X[12] := 0; X[13] := -0.02; X[14] := 14.5; X[15] := 123.7; { Инициализация переменных для поиска минимального элемента } minValue := X[1]; minIndex := 1; { Поиск минимального элемента и его номера } for i := 2 to N do begin if X[i] < minValue then begin minValue := X[i]; minIndex := i; end; end; { Вывод результатов } writeln('Массив X:'); for i := 1 to N do begin writeln('X[', i, '] = ', X[i]:0:2); end; writeln('Наименьший элемент: ', minValue:0:2); writeln('Номер наименьшего элемента: ', minIndex); end.
Программа объявляет массив X с 15 элементами и заполняет его значениями, как указано в задании. Затем она проходит по массиву, ищет наименьший элемент и его номер. Результат работы программы будет выведен на экран, включая значения массива и номер наименьшего элемента.
Пожалуйста, скопируйте этот код в среду разработки Паскаля и запустите программу для получения результатов.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
