Вопрос задан 12.07.2023 в 12:07. Предмет Информатика. Спрашивает Лебедев Павел.

Помогите пожалуйста 1) Составить программу в Паскале для обработки одномерного массива из 15

чисел. Значения элементов массива задать с клавиатуры самостоятельно. Найти наименьший элемент массива и его номер. В отчет включить программный код и результат работы программы в виде скриншота. Программная реализация обязательна. 2) Составить программу в Паскале для обработки одномерного массива из 10 чисел Х=(-17,3; 13,2; -7; -2,36; 123,4;-0,3; 12,356; 142;0; -1). Вычислить количество элементов массива с нечетными номерами на отрезке [5,1..32,4]. В отчет включить программный код и результат работы программы в виде скриншота. Программная реализация обязательна.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дашидондокова Алена.

1.

program mas_min_el_i_no;

const n=15;

var

a:array[1..n]of integer;

i,m,k:integer;

begin

for i:=1 to n do

begin

write(i,'》');

read(a[i]);

end;

m:=a[1];

k:=1;

for i:=1 to n do

if a[i]<m then

begin

m:=a[i];

k:=i;

end;

writeln;

write(m,' ',k)

end.

2.

program mas_kolel_v_otr_s_nech_ind;

const

x:array[1..10]of real=(-17.3, 13.2, -7, -2.36, 123.4,-0.3, 12.356, 142,0, -1);

var

i,k:byte;

begin

k:=0;

for i:=1 to 10 do

if (x[i]>=5.1)and(x[i]<=32.4)and(i mod 2<>0) then

inc(k);

write(k)

end.



0 0
Отвечает Героев Никита.

===== PascalABC.NET ====

= 1 =

begin

 var a := ReadArrInteger(15);

 var i := a.IndexMin;

 Print('Минимальный элемент номер', i + 1, 'равен', a[i])

end.

= 2 =

begin

 var x : array of real :=

     (-17.3, 13.2, -7, -2.36, 123.4, -0.3, 12.356, 142, 0, -1);

 x.Indices((v,i) -> i.IsEven and (v >= 5.1) and (v <= 32.4))

     .Count.Print

end.



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам с этим. Вот программы на языке Паскаль для выполнения задачи 1 и задачи 2:

Задача 1:

pascal
program MinElementSearch; const N = 15; var arr: array[1..N] of real; minElement: real; minIndex: integer; i: integer; begin writeln('Введите ', N, ' элементов массива:'); for i := 1 to N do readln(arr[i]); minElement := arr[1]; minIndex := 1; for i := 2 to N do begin if arr[i] < minElement then begin minElement := arr[i]; minIndex := i; end; end; writeln('Наименьший элемент массива: ', minElement); writeln('Индекс наименьшего элемента: ', minIndex); readln; end.

Задача 2:

pascal
program OddElementCount; const N = 10; var arr: array[1..N] of real; oddCount: integer; i: integer; begin arr[1] := -17.3; arr[2] := 13.2; arr[3] := -7; arr[4] := -2.36; arr[5] := 123.4; arr[6] := -0.3; arr[7] := 12.356; arr[8] := 142; arr[9] := 0; arr[10] := -1; oddCount := 0; for i := 5 to 10 do begin if i mod 2 = 1 then begin if (arr[i] >= 1.32) and (arr[i] <= 32.4) then oddCount := oddCount + 1; end; end; writeln('Количество элементов с нечетными номерами на отрезке [5,1..32,4]: ', oddCount); readln; end.

Пожалуйста, учтите, что вам может потребоваться настроить среду программирования для компиляции и выполнения этих программ. Если у вас возникнут вопросы, не стесняйтесь спрашивать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос