Помогите по информатике по Паскалю 3) Из элементов массива Р сформировать массив М той же
размерности по правилу: если номер четный, то М[I]=I*P[I],если нечетный, то M[I]=-P[I].5) Составить программу вычисления и печати значений функции Y=(sinx+1)√cos4x. Значения аргументов задать в массиве X, состоящего из 10 элементов. Значения функции записать в массив Y.6) Заменить первые К элементов массива на противоположные по знаку.Ответы на вопрос
Program n3;
const n=5;
var p,m: array[1..n] of integer;
i: integer;
begin
for i:=1 to n do begin
read(p[i]);
if i mod 2=0 then m[i]:=i*p[i] else m[i]:=(-1)*p[i];
end;
writeln;
for i:=1 to n do write(m[i],' ');
end.
Program n5;
const n=10;
var x,y: array[1..n] of real;
i: integer;
begin
for i:=1 to n do begin
read(x[i]);
y[i]:=(sin(x[i])+1)*sqrt(cos(4*x[i]));
end;
writeln;
for i:=1 to n do write(y[i],' ');
end.
Program n6;
const n=5;
var a: array[1..n] of integer;
i,k: integer;
begin
readln(k);
for i:=1 to n do read(a[i]);
writeln;
for i:=1 to k do a[i]:=(-1)*a[i];
for i:=1 to n do write(a[i],' ');
end.
Для выполнения каждой из задач на языке программирования Паскаль (Pascal) потребуется написать соответствующий код. Ниже представлены решения каждой задачи.
- Из элементов массива Р сформировать массив М той же размерности по правилу: если номер четный, то М[I] = I * P[I], если нечетный, то M[I] = -P[I].
pascalprogram Task3; const N = 10; // Размерность массива var P, M: array[1..N] of Integer; I: Integer; begin // Здесь заполняем массив P значениями (вводом с клавиатуры или как-либо еще) for I := 1 to N do begin if I mod 2 = 0 then M[I] := I * P[I] else M[I] := -P[I]; end; // Здесь выводим полученный массив M for I := 1 to N do Write(M[I], ' '); end.
- Составить программу вычисления и печати значений функции Y = (sin(x) + 1) * sqrt(cos(4 * x)). Значения аргументов задать в массиве X, состоящего из 10 элементов. Значения функции записать в массив Y.
pascalprogram Task5; uses Math; const N = 10; // Размерность массива var X: array[1..N] of Real; Y: array[1..N] of Real; I: Integer; begin // Здесь заполняем массив X значениями (вводом с клавиатуры или как-либо еще) for I := 1 to N do begin Y[I] := (Sin(X[I]) + 1) * Sqrt(Cos(4 * X[I])); end; // Здесь выводим массив Y с результатами for I := 1 to N do Write(Y[I]:0:2, ' '); end.
- Заменить первые К элементов массива на противоположные по знаку.
pascalprogram Task6; const N = 10; // Размерность массива var A: array[1..N] of Integer; K, I: Integer; begin // Здесь заполняем массив A значениями (вводом с клавиатуры или как-либо еще) // Задаем значение для переменной K (сколько элементов нужно заменить) for I := 1 to K do begin A[I] := -A[I]; // Заменяем элемент на противоположный по знаку end; // Здесь выводим полученный массив A for I := 1 to N do Write(A[I], ' '); end.
Обратите внимание, что в каждой программе необходимо заполнить массивы значениями, например, с помощью ввода с клавиатуры или задать их как-либо еще до начала вычислений. Также можно добавить дополнительные проверки для корректности введенных данных и обработку исключительных ситуаций.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
