C++ Напишите программу, которая получает с клавиатуры количество повторений и выводит столько же
раз какое-нибудь сообщение.Ответы на вопрос
Ответ:
#include <iostream>
using namespace std;
int main()
{
int n;
cin >> n;
while(n--)
cout << "Here we go" << endl;
}
Конечно! Вот пример программы на C++, которая получает с клавиатуры количество повторений и выводит сообщение указанное количество раз:
cpp#include <iostream>
#include <string>
int main() {
int repeatCount;
std::string message;
// Получаем количество повторений
std::cout << "Введите количество повторений: ";
std::cin >> repeatCount;
// Очищаем буфер после ввода числа
std::cin.ignore(std::numeric_limits<std::streamsize>::max(), '\n');
// Получаем сообщение
std::cout << "Введите сообщение: ";
std::getline(std::cin, message);
// Выводим сообщение указанное количество раз
for (int i = 0; i < repeatCount; i++) {
std::cout << message << std::endl;
}
return 0;
}
В этой программе мы используем переменные repeatCount для хранения количества повторений и message для хранения введенного сообщения. Затем мы считываем количество повторений с помощью std::cin, используя оператор >>, а сообщение считываем с помощью std::getline.
Затем мы используем цикл for для вывода сообщения указанное количество раз. Каждое сообщение выводится с помощью std::cout << message << std::endl;.
Пожалуйста, обратите внимание, что в этом примере предполагается, что введенное количество повторений будет корректным целым числом, а введенное сообщение может содержать пробелы и специальные символы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
