Написать программу нахождения периметра прямоугольника. Значения длины и ширины на языке codeblocks
Ответы на вопрос
#include <iostream>
using namespace std;
int main()
{
int a,b;
cin>>a>>b;
cout<<a+a+b+b;
}
прошу))
#include <iostream>
int main()
{
std::ios_base::sync_with_stdio(false);
std::cin.tie(nullptr);
int length, width;
std::cout << "Length: ";
std::cin >> length;
std::cout << "Width: ";
std::cin >> width;
std::cout << "Perimeter: " << 2 * (width + length);
system("pause");
return 0;
}
Для нахождения периметра прямоугольника, нужно умножить сумму его сторон (длины и ширины) на 2, так как периметр это сумма всех сторон.
Вот пример программы на языке C++ в среде Code::Blocks:
cpp#include <iostream>
int main() {
// Объявляем переменные для длины и ширины прямоугольника
double length, width;
// Запрашиваем у пользователя значения длины и ширины прямоугольника
std::cout << "Введите длину прямоугольника: ";
std::cin >> length;
std::cout << "Введите ширину прямоугольника: ";
std::cin >> width;
// Вычисляем периметр прямоугольника
double perimeter = 2 * (length + width);
// Выводим результат на экран
std::cout << "Периметр прямоугольника: " << perimeter << std::endl;
return 0;
}
Скопируйте этот код в среду Code::Blocks, скомпилируйте и запустите программу. После запуска она попросит вас ввести значения длины и ширины прямоугольника, а затем выведет на экран его периметр.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
