Вопрос задан 21.03.2021 в 13:40. Предмет Информатика. Спрашивает Савельев Женя.

1. Написать программу на алгоритмическом языке и блок-схему нахождения суммы двух чисел. Числа

вводятся с клавиатуры.2. Написать программу на алгоритмическом языке и блок-схему.Найти периметр треугольника. Длины сторон вводятся с клавиатуры.3. Написать программу на алгоритмическом языке и блок-схему нахождения периметра и площади прямоугольника. Стороны прямоугольника вводятся с клавиатуры.РЕШИТЕ ПОЖАЛУЙСТА
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Омирбеков Арман.

1)var a,b:integer;

begin

   readln(a,b);

   write(a+b);

end.


2)

var a,b,c:integer;

begin

   readln(a,b,c);

   write(a+b+c);

end.


3)

1)var a,b:integer;

begin

   readln(a,b);

write((a+b)*2);

   write(a*b);

end.

блок-схемы на фото


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот решения в виде программ на псевдокоде (алгоритмическом языке) и соответствующие блок-схемы для каждой задачи:

  1. Нахождение суммы двух чисел:
less
// Алгоритмический язык: Программа НайтиСумму Вывести "Введите первое число: " Считать a Вывести "Введите второе число: " Считать b сумма = a + b Вывести "Сумма чисел равна ", сумма Конец Программы

Блок-схема:

lua
+----------------+ | Введите первое | | число: | +-------+--------+ | | v +-------+--------+ | Считать a | +-------+--------+ | | v +----------------+ | Введите второе | | число: | +-------+--------+ | | v +-------+--------+ | Считать b | +-------+--------+ | | v +-------+--------+ | сумма = a | | + b | +-------+--------+ | | v +----------------+ | Вывести "Сумма | | чисел равна ", | | сумма | +-------+--------+ | | v
  1. Нахождение периметра треугольника:
arduino
// Алгоритмический язык: Программа НайтиПериметр Вывести "Введите длину первой стороны: " Считать a Вывести "Введите длину второй стороны: " Считать b Вывести "Введите длину третьей стороны: " Считать c периметр = a + b + c Вывести "Периметр треугольника равен ", периметр Конец Программы

Блок-схема:

lua
+-----------------------------+ | Введите длину первой стороны: | +-------+---------------------+ | | v +-------+-------+ | Считать a | +-------+-------+ | | v +-----------------------------+ | Введите длину второй стороны: | +-------+---------------------+ | | v +-------+-------+ | Считать b | +-------+-------+ | | v +-----------------------------+ | Введите длину третьей стороны:| +-------+---------------------+ | | v +-------+-------+ | Считать c | +-------+-------+ | | v +-----------------------------+ |
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос