
Программа в паскале, СРОЧНО! Запросить a и bВывести числа от 1 до а, b строкНапример запросили 7
и 3Вывести должно :123456712345671234567Как можно скорее, пожалуйста 

Ответы на вопрос

Ответ:
program prog;
var a, b, i, j:Integer;
begin
ReadLn(a, b);
for i:= 1 to b do
begin
for j:= 1 to a do
begin
Write(j);
end;
WriteLn();
end;
end.



Для того чтобы написать программу на Pascal, которая будет выводить числа от 1 до а, b строк, можно использовать два цикла. Один цикл будет отвечать за вывод строк, а второй - за вывод чисел в каждой строке. Вот код программы на Pascal:
pascalprogram OutputNumbers; var a, b, i, j: integer; begin // Вводим значения a и b writeln('Введите a:'); readln(a); writeln('Введите b:'); readln(b); // Цикл для вывода b строк for i := 1 to b do begin // Цикл для вывода чисел от 1 до a в каждой строке for j := 1 to a do begin write(j); end; writeln; // Переходим на новую строку после вывода чисел end; end.
Скопируйте этот код в среду программирования на Pascal (например, Lazarus или Free Pascal), и запустите программу. Она запросит ввод значений a и b, а затем выведет числа от 1 до a, b строк. В вашем примере с a=7 и b=3, результат будет точно таким, как вы указали:
1234567 1234567 1234567
Надеюсь, это поможет вам с вашей срочной задачей! Если у вас возникнут ещё вопросы, не стесняйтесь задавать. Удачи!


Похожие вопросы
Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili