Вопрос задан 13.07.2023 в 09:36.
Предмет Информатика.
Спрашивает Бадина Александра.
Напишите программу, печатающую количество максимальных элементов непустого массива. Язык С++
Ответы на вопрос
Отвечает Диульский Сергей.
#include <iostream>
using namespace std;
int
main ()
{
int n, i, t = 1, m, a[100]; \\ можно поставить свои ограничения;
cin >> n;
for (i = 0; i < n; i++)
cin >> a[i];
m = a[0] - 1;
for (i = 0; i < n; i++)
{
if (a[i] > m)
{
m = a[i];
t = 0;
};
if (a[i] == m)
t++;
};
cout << t;
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи, мы можем написать программу на языке C++, которая принимает входные данные массива, находит максимальный элемент и подсчитывает количество его вхождений в массиве. Вот пример программы:
cpp#include <iostream>
#include <vector>
int main() {
int n;
std::cout << "Введите размер массива: ";
std::cin >> n;
if (n <= 0) {
std::cout << "Размер массива должен быть положительным числом." << std::endl;
return 1;
}
std::vector<int> arr(n);
std::cout << "Введите элементы массива через пробел: ";
for (int i = 0; i < n; ++i) {
std::cin >> arr[i];
}
// Находим максимальный элемент
int maxElement = arr[0];
for (int i = 1; i < n; ++i) {
if (arr[i] > maxElement) {
maxElement = arr[i];
}
}
// Считаем количество максимальных элементов в массиве
int count = 0;
for (int i = 0; i < n; ++i) {
if (arr[i] == maxElement) {
count++;
}
}
std::cout << "Количество максимальных элементов: " << count << std::endl;
return 0;
}
В этом коде мы сначала запрашиваем размер массива, затем заполняем его элементами, после чего находим максимальный элемент и считаем количество его вхождений в массиве. Результат выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
