Вопрос задан 13.07.2023 в 03:41.
Предмет Информатика.
Спрашивает Боже Дмитрий.
Написать программу Паскаль дано целое положительное число напечатать количество и сумму его
цифр.ПожалуйстаОтветы на вопрос
Отвечает Ганиева Севиль.
var
n, i, count, sum: integer;
begin
Writeln('Ввидете число: ');
Read(n);
count := 0;
while n <> 0 do
begin
i := n mod 10;
sum += i;
count += 1;
n := n div 10;
end;
Writeln('Сумма всех цифр: ', sum);
Writeln('Количество цифр: ', count);
end.
Тестовое решение
Введите число:
51231
Сумма всех цифр: 12
Количество цифр: 5
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы на языке Паскаль, которая будет считать количество и сумму цифр данного целого положительного числа, можно использовать следующий код:
pascalprogram CountAndSumDigits; var num, digit, sum, count: integer; begin // Вводим число с клавиатуры writeln('Введите целое положительное число:'); readln(num); // Инициализируем сумму и количество цифр sum := 0; count := 0; // Выполняем цикл пока число не станет равным нулю while num > 0 do begin // Получаем последнюю цифру числа digit := num mod 10; // Добавляем цифру к сумме sum := sum + digit; // Увеличиваем количество цифр на 1 count := count + 1; // Убираем последнюю цифру из числа num := num div 10; end; // Выводим результаты writeln('Количество цифр в числе: ', count); writeln('Сумма цифр числа: ', sum); end.
Скопируйте этот код в среду разработки Pascal (например, Free Pascal или Turbo Pascal) и запустите программу. Она попросит вас ввести целое положительное число, после чего выдаст количество цифр и сумму цифр данного числа.
Похожие вопросы
Информатика 76
Информатика 93
Информатика 62
Информатика 66
Информатика 220
Информатика 18
Информатика 38
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
