C# . СРОЧНО . Помогите написать программу . Дано двузначное число , определить в нем сумму цифр.
Ответы на вопрос
Ответ:
using System;
namespace ConsoleApp1
{
class Program
{
static void Main(string[] args)
{
int x = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Сумма цифр введенного двухзначного числа: " + (x % 10 + x / 10));
}
}
}
Конечно, я могу помочь вам написать программу на C#, которая будет определять сумму цифр в двузначном числе. Вот пример такой программы:
csharpusing System;
class Program
{
static void Main()
{
Console.Write("Введите двузначное число: ");
int number = int.Parse(Console.ReadLine());
int sum = SumOfDigits(number);
Console.WriteLine("Сумма цифр: " + sum);
Console.ReadLine();
}
static int SumOfDigits(int number)
{
int tens = number / 10; // получаем первую цифру
int units = number % 10; // получаем вторую цифру
int sum = tens + units; // суммируем цифры
return sum;
}
}
В этом примере мы считываем двузначное число с помощью Console.ReadLine(), затем используем метод SumOfDigits, чтобы вычислить сумму цифр. Метод SumOfDigits разделяет число на десятки и единицы, а затем суммирует их. Результат выводится на экран.
Надеюсь, это поможет вам! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
