1)Дан массив действительных чисел размерность которого n подсчитать сколько в нем положительных
элементов C++ 2) дан одномерный массив найти произведение нечетных элементов C++ Находить через массивОтветы на вопрос
        Ответ:
1)
#include <iostream>
using namespace std;
int main()
{
int n,cht;
cht = 0;
float a;
cin >> n;
float mas[10000];
for (int i = 0; i < n; i++) {
cin >> a;
if (a > 0) { cht++; }
}
cout << cht;
}
2)
#include <iostream>
using namespace std;
int main()
{
int n, cht;
cht = 1;
int a;
cin >> n;
int mas[10000];
for (int i = 0; i < n; i++) {
cin >> a;
if (a % 2 == 1) { cht=cht * a; }
}
cout << cht;
}
Объяснение: Будет не понятно, задавай вопросы, удачи.
            Для решения обеих задач вам потребуется написать программу на языке C++. Вот решение каждой из задач:
- Подсчет количества положительных элементов в массиве:
 
cpp#include <iostream>
int countPositiveElements(double arr[], int n) {
    int count = 0;
    for (int i = 0; i < n; i++) {
        if (arr[i] > 0) {
            count++;
        }
    }
    return count;
}
int main() {
    const int n = 5; // Задайте размерность массива, например, 5
    double arr[n];
    
    // Заполнение массива элементами (для примера, вводим с клавиатуры)
    std::cout << "Введите " << n << " элементов массива:\n";
    for (int i = 0; i < n; i++) {
        std::cin >> arr[i];
    }
    int positiveCount = countPositiveElements(arr, n);
    std::cout << "Количество положительных элементов в массиве: " << positiveCount << std::endl;
    return 0;
}
- Нахождение произведения нечетных элементов массива:
 
cpp#include <iostream>
int main() {
    const int n = 5; // Задайте размерность массива, например, 5
    int arr[n];
    
    // Заполнение массива элементами (для примера, вводим с клавиатуры)
    std::cout << "Введите " << n << " элементов массива:\n";
    for (int i = 0; i < n; i++) {
        std::cin >> arr[i];
    }
    int oddProduct = 1;
    for (int i = 0; i < n; i++) {
        if (arr[i] % 2 != 0) {
            oddProduct *= arr[i];
        }
    }
    std::cout << "Произведение нечетных элементов массива: " << oddProduct << std::endl;
    return 0;
}
Обе программы позволят вам решить соответствующие задачи. Вы можете задать размерность массива и ввести его элементы самостоятельно.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			