
Вопрос задан 12.07.2023 в 06:19.
Предмет Информатика.
Спрашивает Верман Кира.
Написать программу Паскаль.Даны два положительных числа.Если квадрат первого числа меньше 28,то
второе число увеличить на 12.Вывести результат.

Ответы на вопрос

Отвечает Брызгалова Александра.
Ответ:
program n1;
var
a, b :integer;
begin
read(a, b);
if not(sqr(a)>28) then
writeln(b+12)
else writeln(sqr(a));
end.
Объяснение:



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы на языке Паскаль, удовлетворяющей условиям, вы можете использовать следующий код:
pascalprogram IncreaseIfSquareLessThan28; var number1, number2: integer; begin writeln('Введите два положительных числа:'); write('Первое число: '); readln(number1); write('Второе число: '); readln(number2); if number1 * number1 < 28 then number2 := number2 + 12; writeln('Результат: ', number2); end.
Пользователь будет приглашен ввести два положительных числа. Затем программа проверит, является ли квадрат первого числа меньше 28, и если это так, то увеличит второе число на 12 и выведет результат.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili