СРОЧНО!!!! ЗАДАЧИ НА ПАСКАЛЬ 2. Даны натуральные числа a и b. Определить тип обыкновенной дроби
a/b (правильная или неправильная), ответ записать в переменную d. 3. Дано целое число х. Если оно двузначное, то в переменную s записать слово “YES”, иначе – слово “NO”. Даю 30 баллов!Ответы на вопрос
1) var a,b:integer;
d:string;
begin
writeln('Введите a,b'); readln(a,b);
if a >= b then d := 'Неправильная'
else d := 'Правильная';
write(d);
end.
2) var
x,k: integer;
begin
writeln('Введите x'); readln(x);
x := abs(x);
while x > 0 do
begin
x := x div 10;
k := k + 1;
end;
if k = 2 then write('YES')
else write('NO');
end.
Для решения задач на Pascal вам потребуется написать программу. Вот решения двух задач:
- Определение типа обыкновенной дроби:
pascalprogram FractionType; var a, b: integer; d: string; begin writeln('Введите числитель (a): '); readln(a); writeln('Введите знаменатель (b): '); readln(b); if (a < b) then d := 'правильная' else d := 'неправильная'; writeln('Тип дроби: ', d); end.
- Определение, является ли число двузначным:
pascalprogram TwoDigitNumber; var x: integer; s: string; begin writeln('Введите целое число x: '); readln(x); if (x >= 10) and (x <= 99) then s := 'YES' else s := 'NO'; writeln('Результат: ', s); end.
Скопируйте код для каждой задачи в отдельные файлы с расширением .pas (например, fraction_type.pas и two_digit_number.pas) и скомпилируйте их с помощью Pascal компилятора (например, Free Pascal) для получения исполняемых файлов. После этого запустите программы, вводите значения для переменных и получите результаты решения задач.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
